Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 10 of 10

Thread: ASRock Z87 Pro4 dual channel memory not working




  1. #1
    Join Date
    Dec 2013
    Location
    Czech Republic
    Posts
    5

    Thumbs down ASRock Z87 Pro4 dual channel memory not working

    Hi,
    so here is my another problem. I am unable to run my memories (Kingston KHX21C11T2K2/16x - they are on supported list) in dual channel mode. When I put memories in positions A1 & B1 or A2 & B2 computer just keeps restarting all the time and not even boot screen displays...nothing.
    However, when I put memories in A1 & A2 or B1 & B2 (not dual channel) I am able to run system smoothly, but in single channel mode!

    I've updated my BIOS to version 1.90, didn't help.

    Memories are tested on another mobo from ASRock - Z77 Extreme (4 or 6, don't know now) and they worked. Also friend of mine borrowed me his memories Kingston 2x4GB and they also refused to work in dual channel.

    Any ideas guys? This is an issue for me for 2 reasons:
    - I want dual channel due to performance
    - I am planning to buy another 2x8GB memories in near future, so with full 4 slots I will have problem again even if I would not agree with single channel mode

  2. #2
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: ASRock Z87 Pro4 dual channel memory not working

    Test them one stick installed at a time using MemTest86+. (<- Link)

    If by testing all you did was see them boot the other computer, that means little. It's THIS/YOUR computer that is apparently having issues/problems.

    On your Z87 run MemTest86+ on each stick individually for 5-8 passes in the program. They should after 5-8 passes be error free. If not suspect that one bad.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  3. #3
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: ASRock Z87 Pro4 dual channel memory not working

    Quote Originally Posted by - wardog - View Post
    On your Z87 run MemTest86+ on each stick individually for 5-8 passes in the program. They should after 5-8 passes be error free. If not suspect that one bad.
    Meaning install one stick on the MB and test it. Then swap for the other one and test it.

    Do this in the slot the MB manual instructs for using 1 stick of memory,.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  4. #4
    Join Date
    Dec 2013
    Location
    Czech Republic
    Posts
    5

    Default Re: ASRock Z87 Pro4 dual channel memory not working

    I've run test 6 times (3 passes for every memory) and no errors.
    Screenshots below after 1st run - just to see mem info.





  5. #5
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: ASRock Z87 Pro4 dual channel memory not working

    Ok. In looking at those pics I guess now is the time to ask you to read and follow #1 in my sig.

    If you've been in the BIOS tinkering with the memory settings prior to this PLEASE clear your BIOS before proceeding with the below suggestion.

    After you do the above I'd like you to go into the BIOS and lets set these up as 1600 by choosing/using XMP Profile #2. Right now those pics tell me you haven't set the memory up as they're showing running at JEDEC defaults of 1333. This still isn't a guarantee that the E3-1245 v3 and HyperX will play nice but its a start at at least determining compatibility.

    Do the above and reply back the results please.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  6. #6
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: ASRock Z87 Pro4 dual channel memory not working

    Excuse me. Please install both sticks before going into the BIOS and set these up using XMP Profile #2. I didn't want you to think I meant do that withone stick. No, have both installed on the board.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  7. #7
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASRock Z87 Pro4 dual channel memory not working

    Quote Originally Posted by spoofan View Post
    Hi,
    so here is my another problem. I am unable to run my memories (Kingston KHX21C11T2K2/16x - they are on supported list) in dual channel mode...
    snip
    Quote Originally Posted by spoofan View Post
    I've run test 6 times (3 passes for every memory) and no errors.
    Screenshots below after 1st run - just to see mem info.

    Wait a second, why does it seem like we are talking about two different models of memory?

    We can see in the Memtest screenshot, the model listed is KHX2133C11D3/8GX.

    The first post lists the memory seen above in the quote, which is this: http://www.kingston.com/datasheets/KHX21C11T2K2_16X.pdf

    I can't find the exact model in the quote above, the closest I can find is this: Kingston HyperX 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model KHX1600C9D3K2/8GX - Newegg.com

    The model listed in the Memtest screenshot looks like it matches another entry in the memory support list, KHX2133C11D3T1K2/16GX, but that memory is this model:

    Kingston Technology KHX2133C11D3T1K2/16GX - 16GB 2133MHz DDR3 Non-ECC CL11

    Which model do you have, the Predator, of either of the two HyperX models?

  8. #8
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: ASRock Z87 Pro4 dual channel memory not working

    Quote Originally Posted by parsec View Post
    Wait a second, why does it seem like we are talking about two different models of memory?
    I don't believe we are. My guess is that's just the way each stick(!), vs kit p/n, presents itself/themself.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  9. #9
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASRock Z87 Pro4 dual channel memory not working

    Ok, just sayin'...

    Otherwise, this issue makes no sense, given that the memory seems to be working, and all the slots seem to be working.

    OTOH, do we know that when both DIMMs are in A1 and A2, etc, (single channel mode) that the BIOS and Windows sees 16GB of memory?

    Good advice, insert the DIMMs in A2 and B2, then clear the CMOS/BIOS, and try again.

    P.S. wardog, your PMs are full or not working again...

  10. #10
    Join Date
    Dec 2013
    Location
    Czech Republic
    Posts
    5

    Default Re: ASRock Z87 Pro4 dual channel memory not working

    Hi,
    thanks for replies.
    My whole configuration was (almost) already mentioned:
    - Intel Xeon E3 1245V3
    - ASRock Z87 Pro4
    - Kingston HyperX Predator 16GB (2x8GB) DDR3 2133 XMP
    - Seagate Barracude 1TB 7200.14
    - Corsair VS650

    I wrote type of memory from package. It is weird that it appears different in memtest.

    I am not able to go into BIOS with both memories put into dual channel positions. So should I try set XMP profile individually for each memory and then put them both into dual channel slots?

    wardog: "This still isn't a guarantee that the E3-1245 v3 and HyperX will play nice but its a start at at least determining compatibility." - Are those components not compatible? Do you suggest any better memories?


    EDIT: set in bios XMP profile 2, tried even to set frequency by hand to 1600 then put both memories in dual channel position and nothing happened. I'm getting desperate :-/ I've cleared CMOS before changes to bios.


    EDIT2: something weird happened...I decided to disassemble whole computer, so I took out CPU, cleared CMOS (live thousand times before), remover memories, "started" computer. Put CPU back, memories back and it was running in dual channel. WTF? Cpu was places correctly before (I was using computer with 1 memory for hours), memories placed into same position like before, CMOS cleared same way like before...So I don't know what was different this time but it's working. However I'm afraid the same problem will come back when I buy another pair of memories....
    Last edited by spoofan; 01-06-2014 at 04:49 AM. Reason: extended answer

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •