Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Fatality Killer - bios only regonise one hard drive




  1. #1
    Join Date
    Jan 2014
    Location
    Melbourne
    Posts
    1

    Default Fatality Killer - bios only regonise one hard drive

    Hi got this board today & having some weird problems, I have several hard drives with windows on or other crap (win 7 & win 8). However I can only get the bios to pick up the same drive every time, it has a win 7 image on that has always worked on other systems however once Windows loads it runs like a dog then will BSOD about 3 minutes later. If I have multiple HD connected the bios only picks up the same one HD all the time, if I dont have that particular drive hooked up then when I boot the bios screen just loads because it cant find a bootable device I have tried different PSU's, sata cables, with my GPU's, without GPU's, clearing cmos, updating bios (currently at the beta version).

    Tearing my hair out, thinking it must be a faulty board but it is such a weird problem. please help me before I smash something :(

  2. #2
    Join Date
    Jun 2014
    Location
    USA
    Posts
    2

    Default Re: Fatality Killer - bios only regonise one hard drive

    Quote Originally Posted by paul8811 View Post
    Hi got this board today & having some weird problems, I have several hard drives with windows on or other crap (win 7 & win 8). However I can only get the bios to pick up the same drive every time, it has a win 7 image on that has always worked on other systems however once Windows loads it runs like a dog then will BSOD about 3 minutes later. If I have multiple HD connected the bios only picks up the same one HD all the time, if I dont have that particular drive hooked up then when I boot the bios screen just loads because it cant find a bootable device I have tried different PSU's, sata cables, with my GPU's, without GPU's, clearing cmos, updating bios (currently at the beta version).

    Tearing my hair out, thinking it must be a faulty board but it is such a weird problem. please help me before I smash something :(
    I am having the exact same problem, even tried a 4 port sata card in both the x1 and x16 video slot and still the same problem.

  3. #3
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Fatality Killer - bios only regonise one hard drive

    Quote Originally Posted by paul8811 View Post
    Hi got this board today & having some weird problems, I have several hard drives with windows on or other crap (win 7 & win 8). However I can only get the bios to pick up the same drive every time, it has a win 7 image on that has always worked on other systems however once Windows loads it runs like a dog then will BSOD about 3 minutes later. If I have multiple HD connected the bios only picks up the same one HD all the time, if I dont have that particular drive hooked up then when I boot the bios screen just loads because it cant find a bootable device I have tried different PSU's, sata cables, with my GPU's, without GPU's, clearing cmos, updating bios (currently at the beta version).

    Tearing my hair out, thinking it must be a faulty board but it is such a weird problem. please help me before I smash something :(
    So you're using Windows installations from other boards with the new board. If the other boards are not the same platform (chipset, CPU type, etc), the Windows installations most likely won't work right, that is to be expected and really a given.

    The way you installed Windows on the other PCs also can make a difference. If more than one drive was in the PC when you installed Windows, it will put the MBR on another drive besides the OS target drive. Then that installation depends on both drives to work.

    Very little info given in your post, but if you can't boot with one drive connected, the situation I described above is probably correct. Given what we know, not a weird problem at all, normal and to be expected, sorry to say. Plus a mix of OS versions, no chance that can work. You need to install Windows again with only one drive powered up in the PC.

  4. #4
    Join Date
    Jun 2014
    Location
    USA
    Posts
    2

    Default Re: Fatality Killer - bios only regonise one hard drive

    I installed a new ssd drive and installed windows 7 on it. Boots fine but Marvell 4 port sata nor the on board sata recognize any of the other HDDs. My DVD ROM and blue ray drives are both seen no matter which sata configuration I use. Bios is updated and set to AHCI I have also tried IDE with no change in HDD visibility. Any suggestion?
    Oh and by the way, if I plug any of the HDDs into the drive dock, which is connected to onboard sata I can see each of them. All cables are new and new 1375 watt PSU. I'm stumped.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •