Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Z77 X4: ASMedia SATA ports interfere with W7 sleep/wake




  1. #1
    Join Date
    Apr 2013
    Location
    US
    Posts
    21

    Default Z77 X4: ASMedia SATA ports interfere with W7 sleep/wake

    * eVGA GTX 660 Ti (331.65, latest driver)
    * ASRock Z77 Extreme4 (2.90, latest BIOS; all drivers up-to-date)
    * I7-3770K
    * WD Caviar Green 2TB
    * 8GB Crucial Ballistix Sport DDR3-1600
    * Samsung 840 Pro 256GB SSD (SATA3_0)
    * Windows 7 Pro SP1 x64 (all updates installed)
    * No overclocking is in use.
    * Dell 3007WFP monitor (2500x1600), DVI connection
    * ASMedia SATA3 drivers (1.3.1, latest)

    Above components have worked perfectly for the past nine months. Today, I added a HGST Deskstar 7K4000 4TB. When I connect it to either of the ASMedia ports (SATA3_A0 or SATA3_A1), Windows 7 does not resume properly from sleep. In particular, the monitor often remains asleep. If I then put the computer back in sleep mode, and then resume again, the monitor does turn on (but my windows have shrunk and moved due to the previous video error).

    When I connect the new HGST disk instead to SATA3_1, the computer works properly again. The problem only occurs when the ASMedia SATA3 ports are in use.
    Last edited by Gary902; 01-24-2014 at 06:58 AM.

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z77 X4: ASMedia SATA ports interfere with W7 sleep/wake

    Your wake from Sleep symptoms with the "monitor" asleep is really the video card failing to wake correctly. I've dealt with this before on a P67 board, which was never resolved.

    If you check the Windows Event log, you will likely find a message about the wake from Sleep failure, and the reason for the failure. If you know what time the wake up event occurred, it is much easier to find the log entry.

    If the Event log entry states something like "... the device or driver did not respond in the expected amount of time...", with a time interval specified (in milliseconds), diagnosing the problem is difficult.

    You already know it is related to the ASMedia controller and possibly its interaction with your Deskstar 7K4000, which is an Advanced Format HDD.

    In the BIOS in Advanced, Storage Configuration, do you have "Aggressive SATA Link Power Management" enabled? If so, disable it.

    Is the ASMedia SATA mode AHCI?

    The 1.3.1 driver you're using is the newest on your board's download page, but is not the latest version. The driver you use might help fix the issue, I cannot guarantee that but it's worth a try. You have a few options:

    Several newer versions available here, the third table on the page is for the ASMedia 1061 SATA chip: Station-Drivers - Asmedia drivers & firmwares

    ASRock has newer driver versions available on some of their newer board's download pages, that use the same ASMedia 1061 SATA chip. The Z87 Ex 4 board has the 1.4.1.0 version: ASRock > Z87 Extreme4

    Or you can use the Windows 7 msahci driver by updating manually with Device Manager.

    I've never heard of the ASMedia SATA controller causing wake from Sleep issues, interesting IMO that you have this issue. Does this happen if you use other HDDs on the ASMedia controller?

    I personally avoid using it for several reasons. You won't lose any performance using this HDD on an Intel SATA II port, since no HDDs can exceed SATA II speeds, even if they are said to be SATA III. The Intel SATA III ports will give much better performance than the ASMedia. I can't use the ASMedia SATA ports at all with Windows 8, slow booting, blue screens, all kinds of issues.

  3. #3
    Join Date
    Apr 2013
    Location
    US
    Posts
    21

    Default Re: Z77 X4: ASMedia SATA ports interfere with W7 sleep/wake

    Thanks for the suggestions. Since things are stable again, I'm hesitant to experiment further right now unless there's a known solution. I see your point about HDD performance; but I may add more SSDs in the future, and it's discouraging that the product doesn't seem to work as advertised.

    Just to add what information I already have: Yes, ASMedia SATA3 mode is AHCI. I did have difficulties with other HDDs as well on the ASMedia ports, but the last time I tried (prior to the new Deskstar 7K4000) was nine months ago and I'm afraid I don't have a record or recollection of the details. I do have Aggressive SATA Link Power Management enabled (that was the default setting), but I consider power management to be important and don't want to partially disable it as a workaround for a defect. Using SATA2 ports seems like a preferable workaround for the moment.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •