Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 6 of 6

Thread: Z87E-ITX SSD being detected intermittently




  1. #1
    SnooSnoo is offline Junior Member
    Join Date
    Jan 2014
    Location
    Croatia
    Posts
    3

    Default Z87E-ITX SSD being detected intermittently

    Almost after every post I have to enter UEFI for the SSD to be recognised. Sometimes it needs several reboots until I see the SSD in the system browser and in the storage/boot menues. I also have 4x500GB 2.5" HDD's that dont behave like the SSD, they are allways detected @ every boot/reboot.

    UEFI has been updated to the latest version, SSD firmware aswell, tried IDE/AHCI/RAID, enabling/disabling every possible storage option and all combinations to no avail. Tried changing 4 different SATA cables, different power connectors, and all SATA connectors on the motherboard. The SSD works without issues in the other 2 computers that I installed it in. Any help would be appreciated.

    Regards, SnooSnoo.

    Config:

    Asrock Z87E-ITX
    i5 4670K
    G.Skill Ares 2x4 GB 1600
    Crosair Force F90 SSD
    Radeon 6950
    Corsair HX 620

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z87E-ITX SSD being detected intermittently

    Uh oh, you have a problem. Your Corsair Force F90 which uses the SandForce 1200 controller is known to not be compatible with Haswell systems like a Z87.

    It's the SandForce 1200 controller that is the problem, the OCZ Vertex II with the same controller was announced as incompatible with Haswell systems by OCZ a while ago.

    Your symptoms of erratic drive detection is the usual problem.

    Google on "vertex 2 haswell compatibility" for more information, here is one thread on this topic:

    First generation Sandforce controller SSD's are not compatible with Haswell

    I don't know what Corsair has said about this, check their SSD support forum.

  3. #3
    SnooSnoo is offline Junior Member
    Join Date
    Jan 2014
    Location
    Croatia
    Posts
    3

    Default Re: Z87E-ITX SSD being detected intermittently

    Oh, boy. My luck... Thanks a lot for posting :) The drive was behaving much better yesterday, after a reinstall of the os and subsequent patches/reboots it had 4 clean reboots in a row. I'll just have to live with Ctrl-Alt-Del-ing for a while untill i get a new SSD then. I'm guessing, even tho they are sandforce drives, that the Intel 530 series should not have any problems with my system? (oh yaeah, you said first gen sandforce) Or would a Samsung 840 pro/evo be a better choice?

    Thanks again, and best regards,

    SnooSnoo.
    Last edited by SnooSnoo; 01-28-2014 at 02:09 PM.

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z87E-ITX SSD being detected intermittently

    Glad I could save you some grief, that is a hard issue to figure out, not that it can be fixed. You are lucky that you can boot from that SSD at all.

    If you are using the Intel IRST AHCI/RAID driver, its Windows UI has Performance and Power saving settings. Set the performance to maximum, and disable the link power management, if it is enabled.

    I've used all three of those SSDs on my ASR Z87 board, and they work fine. Yes it is only the SandForce 1200 controller that has the problem, that has not been used for a while now. One strange thing, the 530 would not be seen in the System Browser, but would be listed as a boot disk and ran the OS fine every time. Intel released a firmware update that fixed that, but the SSD never really had a problem.

    If the 530 is the same price as the 840 Pro, get the 840 Pro. If the EVO is the same price as the 530, consider the EVO is faster but has a three year warranty, the 530 a five year warranty.

  5. #5
    SnooSnoo is offline Junior Member
    Join Date
    Jan 2014
    Location
    Croatia
    Posts
    3

    Default Re: Z87E-ITX SSD being detected intermittently

    Very good info. I have to thank you again kind Madam/Ser, much obliged.

    Regards, SnooSnoo.
    Last edited by SnooSnoo; 01-28-2014 at 03:17 PM.

  6. #6
    Join Date
    Oct 2014
    Location
    South Africa
    Posts
    2

    Default Re: Z87E-ITX SSD being detected intermittently

    Great information! Thank you.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •