Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: ASRock z68 Extreme3 Gen3 760 gtx card no display




  1. #1
    Join Date
    Feb 2014
    Location
    Virginia
    Posts
    3

    Default ASRock z68 Extreme3 Gen3 760 gtx card no display

    Hello guys I seem to be having bit of a problem here. Did a lot of searching and still havent got a solution. I built this pc 2 years ago with a evga 570 gtx that was working flawless...no problems at all. Today I recieved my evga 760 gtx, replaced the old card and got no display. I tried installing drivers and got nothing. Wipe all drivers, tried putting it in slot #2, tried putting both in, tried updating bios to most recent, works in friends pc, tried the driver cd that came with it, list goes on. i tried just about everything. 570 gtx works fine but the mobo wont recognize my 760 for some reason. Now i am in the process of reinstalling Windows 7 64 bit. Do i need some custom bios? Does someone have these same problems?

  2. #2
    Join Date
    Feb 2014
    Location
    Virginia
    Posts
    3

    Default Re: ASRock z68 Extreme3 Gen3 760 gtx card no display

    I dont think im ever buying ASrock products again. I even flash the beta bios and still does not recognize my 760 gtx. Ridiculous

  3. #3
    Spyone1 is offline Member
    Join Date
    Jan 2014
    Location
    Australia
    Posts
    102

    Default Re: ASRock z68 Extreme3 Gen3 760 gtx card no display

    It would help if you listed the details of your PC.

    MAIN PC
    CPU
    - i7-3820 @ 3.60Ghz
    MB - AsRock X79 Extreme6 (Bios P2.80)
    RAM - 2 x 8Gb Patriot Viper 1866 CL10 Series @933Mhz
    GPU - ASUS Radeon HD 7870 Direct CU II (2Gb) x 2 (XFire)
    CASE - Fractal Design Desire R4 Black Case (windowless)
    FANS - Standard Fan CPU, 5 x FD Silent 2 140mm Fans in case
    PSU - Thermaltake R2 800W
    SSD - Sandisk SDSSDHP2 240Gb (boot)
    HDD - 2 x Seagate ST2000DM001 2Tb HDD (Storage)
    SYS - Win7 x64 Ultimate
    KB - Logitech K350 Wireless
    MOU -
    Razor Naga Molten mouse
    MON - ASUS VS247H (1920 x 1080)
    UPS - Belkin Line Interactive 1400VA 840W
    System is not overclocked at all.
    2ND PC
    AMD FM2 A10-7850K @ 3.70Ghz
    AsRock FM2A88X Extreme6+ (Bios P2.90)
    2 x 4Gb G.Skill Ripjaws F3-12800CL9D-8GBXL

    Kaveri Spectre Desktop (onboard) @ 760Mhz
    Thermaltake V9 case (1 x 120mm, 1 x 240mm fan)
    Corsair H80i Water Cooler w/2 x 120mm fans
    Seasonic G-Series (SSR-650RM Active PFC F3) 650W

    OCZ Vertex 4 120Gb SSD (Boot)
    2 x ST2000DM001 2Tb HDD (Storage)
    Win7 X64 Ultimate
    Logitech G15 (6 G Keys) USB
    Logitech MX-518 mouse
    Phillips 22HFL3350D/10 (1920 x 1080)
    NAS - Netgear RN104-100AJS 4 Bay (not hooked in)
    Not overclocking


  4. #4
    Join Date
    Feb 2014
    Location
    Virginia
    Posts
    3

    Default Re: ASRock z68 Extreme3 Gen3 760 gtx card no display

    Quote Originally Posted by Spyone1 View Post
    It would help if you listed the details of your PC.
    i5 2500k sandy
    Asus z68 extreme3 gen3 motherboard
    G.skill ripjaws 4g x 2
    Evga 570 gtx for now
    850w cosair certified psu
    Standard hd
    No cd drive
    Windows 7 ultimate
    Lastest beta bios for my board
    Bios is at default settings

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •