Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: Having problems after bios update




  1. #1
    Join Date
    Feb 2014
    Location
    lithuania
    Posts
    3

    Default Having problems after bios update

    Spec:
    asrock z77 pro3
    Intel i5 3750k
    Gtx 560
    I was updating bios throught the windows in the middle of update pc freezes .Tried to restart pc . It turns on everything working good it gives 3 short beebs pause 3 short beeps and screen is black mouse and keyboard doesnt work too . I have tried ewerything clear cmos take out cmos battery vga cable another video card
    Can i repair this or no ? Thx for the help

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Having problems after bios update

    If the update froze in Windows, it did not complete. You should see a prompt to restart the PC if it completed. The Windows BIOS update method is the worst to use, they tend to fail. Instant Flash is the safest method.

    If you can't get into the BIOS, you might want to get a new BIOS chip from ASRock, they can be replaced.

  3. #3
    Join Date
    Feb 2014
    Location
    lithuania
    Posts
    3

    Default Re: Having problems after bios update

    Sorry for dum question which one is bios chip?

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Having problems after bios update

    It's the chip with the white label on it at the top of the picture to the right of the 24 pin power connector, above where is says "SATA 6Gb/s", which is upside down in this picture:

    Having problems after bios update-z77-pro3-board-jpg

    The chip is in a socket and can be removed, otherwise it would be impossible to replace.

    So you are not trying another method to fix this? Like the ones I mentioned in my other post?

  5. #5
    Join Date
    Feb 2014
    Location
    lithuania
    Posts
    3

    Default Re: Having problems after bios update

    The insta flash method ? Dont work

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •