Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: ASRock Z87 Extreme4 - Freezing on boot screen

  1. #11
    Join Date
    Sep 2014
    United States

    Default Re: ASRock Z87 Extreme4 - Freezing on boot screen

    you have wireless keyboard?
    try wired key to get into bios worked for me.
    Or try ASRock Restart to UEFI.
    With my system (wireless mouse/key) Restart to UEFI brings up bios but I don't have any input

    My freeze on resume problem came back.
    Seems to be after system is sleeping for a while maybe going into S4-S5 deep sleep. Turning off deep sleep in bios no help.

    Otherwise this system is perfect.
    I wonder if Installing and activating rapidstart might work around?
    Or how can I prevent deep sleep?
    Resume works OK if done with a minute of sleep.
    Last edited by Asrocket; 12-19-2014 at 04:43 AM.

  2. #12
    exracer1 is offline Junior Member
    Join Date
    Oct 2014
    Crestline, Ca

    Default Re: ASRock Z87 Extreme4 - Freezing on boot screen

    No it's wired.

  3. #13
    Join Date
    Feb 2014

    Default Re: ASRock Z87 Extreme4 - Freezing on boot screen

    Quote Originally Posted by exracer1 View Post
    I have an X99X Killer with a very similar problem, except mine hangs right after first post, before entering BIOS when I push F2, right after Windows starts and after Windows closes. I tried this solution and all of the hangs disappeared except the one after Windows starts. A new problem has arisen, Now when I choose to go into BIOS it won't. The only way I found to get back in is to reset the BIOS. Any ideas?

    Hello, yes I have to restart the bios every time I want to make changes in it as well becuse the only way to get the freezes to stop is to disable USB devices at boot and at BIOS. A way around could be using a PS/2 keyboard ( if you have the port), I have considered trying it but havent gotten a PS/2 keyboard yet.

  4. #14
    Join Date
    Apr 2017

    Red face Re: ASRock Z87 Extreme4 - Freezing on boot screen

    Quote Originally Posted by Arskad0 View Post
    Hello forum!
    I think I managed to get rid of the problem with the computer sometimes freezing on the motherboard splash screen on boot. It seemed like the more USB devices where connected the more often the problem happened. I went to UEFI -> Advanced -> USB configuration and set; Legacy USB support to UEFI setup only and Legacy usb 3.0 support to disabled. The random boot freezes did stop with that. It seemed almost like the motherboard/ PSU where not able to give power to USB devices and SATA devices at the boot sometimes. But this fixed it to me, hope it does help some one else as well!
    wow - I have been trying to sort out freeze on Mobo splash screen for ages :( never would have suspected USB (I had 10 or so lol) your solution worked - thank you !!!!

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 5 users browsing this thread. (0 members and 5 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts