Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Z87E-ITX cold boot problems and others




  1. #1
    Join Date
    Sep 2008
    Posts
    3

    Default Z87E-ITX cold boot problems and others

    Dear ASROCK gurus:

    I recently built a new rig based on the Z87E-ITX (full specs at the end). I have owned it for almost a month now. I encountered the following problems (first one being the most annoying so far):

    A. The system would not cold boot:

    Simply, the machine won't start from cold boot. I could see the ASROCK Splash logo, and the UEFI options ("Press F2 or Del to UEFI setting, press F11 to Boot options ....") but after the UEFI options faded away, the machine would turn off (the power LED on the case was completely off). No matter how many times I tried to turn on again, the machine would keep doing this endlessly.

    The only way to boot successfully is to press any of the keys as suggested on the options: F2 to UEFI settings, F11 to boot options, etc., then after allowing it to proceed as such the machine would finally boot.

    This affects normal ("disabled" fast boot), "Fast", and "Ultra Fast" boot modes all the same.

    If the machine was just turned off, within a few minutes this problem wouldn't occur. However, after being off for more than a few minutes this would happen. Because of this behavior, I suspected it had something to do with volatile memory (e.g. DRAM or any RAM-based storage) since volatile memory can hold its charge up to a few minutes. On the other hand, I did not see any settings to be altered in UEFI so I am not sure whether this argument is valid. Another thing I can think of would be UEFI bugs.

    Restarting from Windows ("Warm boot") would not result in this problem either. Waking up from Hibernation, if the machine was put to hibernation for a while, would cause the same issue.


    B. The system couldn't recognize UEFI GOP-complaint VBIOS (reliably at least):

    I flashed my VBIOS of the add-on video card (an MSI GTX760) trying to enable the ultra fast boot. When it worked (or at least when I thought it worked) I could see the ASROCK Splash icon displayed in the monitor's native 1920x1200 resolution, different from otherwise (normal or fast boot) when it was displayed at VGA 640x480 resolution. However, it only worked intermittently. When it failed, it seemed to be the same as problem A., that it happened more often in cold boot. The ASROCK splash logo would disappear, then an error message would pop up saying the VBIOS did not conform to UEFI GOP and I could choose to either proceed by pressing F1 (and the UEFI would automatically change the boot mode to "Fast"; I verified it afterwards), or pressing F2/Del to enter UEFI (to do the same thing anyways). MSI support team said it has to do with the motherboard's UEFI implementation. I suspect this has the same root of problems as the first issue above. Is there any suggestion?


    I have contacted the support at ASROCK but so far only got response regarding problem B, saying they are investigating and suggesting me to try another video card (which I don't have the luxury of), and haven't heard anything about the problem A (only automated reply message back to me). Aside from these two, the system works pretty well once booted, and I have tried a few stress tests without major issues. There are some other minor things that I can live with so I won't crowd this post with them.

    My setup:

    ASROCK Z87E-ITX UEFI Ver. 2.30: came with it, also a sticker on the box saying "New Version"
    Xeon 1245v3 @ 3.4 GHz: disabled all core enhancement, enabled all power-saving features except for "C package".
    ADATA XPG 1.0 (XMP profile 1.3) DDR3-1600 2x8GiB @ 9-9-9-24, had to manually select the XMP 1.3 profile to correctly time it as DDR3-1600 (by default the UEFI made it DDR3-1333)
    SATA_0: Samsung 840 Pro 256 GB SSD, set as "Solid state drive" in UEFI, AHCI boot, GPT partitioned, 3 partitions created by Windows 8.1 x64 installer.
    SATA_1: Seagate SSHD 2TB, set as "Hard disk drive" in UEFI, GPT partitioned, one partition.
    SATA_4: LG 14X BD-RE
    Seasonic 520W Platinum silent modular PSU
    Zalman CNPS 8900 Silent CPU cooler
    Cooler Master Elite 130

    Windows 8.1 Pro x64 was installed fresh (with both SSD and SSHD brand new), under UEFI Fast boot, partitioned to use the entire drive in both drives under GPT theme, and all drivers were downloaded from ASROCK website before installation.

    Thanks!

  2. #2
    Join Date
    Sep 2008
    Posts
    3

    Exclamation Re: Z87E-ITX cold boot problems and others

    Looks like nobody has an answer. I got an email from John at Asrock America who suggested changing the RAM to single channel only, load UEFI defaults, which didn't work. He also suggested changing to another RAM. I realized my original ADATA RAM is actually not listed as compatible (the module number differs by a few digits....) so I got a new pair, Kingston KHX1600C10D3B1K2/16G. At first they seem to work (BTW, swapping those RAM modules inside an mITX chassis is very painful), but the problems recur. I just emailed John back again, but wonder whether anyone here could provide some insight. Thanks!

  3. #3
    Join Date
    Sep 2008
    Location
    St. Louis, MO
    Posts
    112

    Default Re: Z87E-ITX cold boot problems and others

    Ever figure this out?
    I7 - 2600K
    Gigabyte Z77X-UD3H (bios F20e mod)
    G.SKILL Ripjaws Z Series 16GB (4 x 4GB)
    Sapphire 7970
    ASUS XONAR DX
    Windows 8.1 64 bit

  4. #4
    Join Date
    Jun 2014
    Location
    Portland, OR
    Posts
    1

    Default Re: Z87E-ITX cold boot problems and others

    I have the exact same problem with my ASRock Z87-itx board. For me, I am unable to boot on any power outage until I reset the bios using the pin-button on the outside of the board.

    Haswell Core i7-4770k
    16mb ram , Crucial Ballistix Sport DDR3-1600 PC3-12800
    NVidia GeForce GTX 560
    ASROCK Z87E-ITX Bios version P2.10 from 10/04/2013

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •