Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: No Signal Video and Update bios with FM2A88x-ITX+




  1. #1
    Join Date
    Mar 2014
    Location
    Canada
    Posts
    1

    Post No Signal Video and Update bios with FM2A88x-ITX+

    Hi,
    I bought a new motherboard and a new processor. When I start my computer I have no Beep and I have no video signal.
    However, the CPU fan is running, the fan chassis work and my hard work.

    Here is my configuration:

    MotherBoard: FM2A88x-ITX+
    Motherboard BIOS version: P1.40-15B
    Processor: AMD A10 7850K
    Memory: KINGSTON 2X8GB PC3 12800 CL11 240
    Video Card #1: APU AMD RADEON HD 8000/7000 SERIE (video card on the motherboard)
    Hard Drive / SSD #1: SEAGATE BARRACUDA SATA 2000GB - 7200 RPM
    Power Supply: 650W
    OS: no OS for the moment

    I tried with another CPU AMD A4 4000 but I the same problem.

    I checked on the website ASROCK and they say it is the bios version is too old.
    I followed the procedure indicated by ASROCK to update from a USB key

    Create a bootable USB pen drive system.
    I downloaded the DOS version of bios V2.10.

    Before I start my computer clear the CMOS data.
    I booted from the USB key.

    But its not working, I still do not have video signal, and I can't update the bios

    I need help please

    thank you

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: No Signal Video and Update bios with FM2A88x-ITX+

    As you know, your AMD A10 7850K processor needs BIOS version 1.50 or newer to be compatible. But your BIOS update to 2.10 would not work.

    You say you also tried an AMD A4 4000 processor, but it did not work. That does not make sense, since that processor should be compatible with any BIOS version:

    ASRock > FM2A88X-ITX+

    Did you try using the bootable DOS pen drive with the A4 4000 processor in the board?

    Clearing the CMOS data like you did will now force you to go into the BIOS and save the default values before you can do anything else.

    I suggest putting the A4 4000 processor in the board, which should start with your 1.40 BIOS. If it does not work, something else is wrong.

    Do you have the four pin CPU power cable from the power supply connected to the plug on the board that is next to the PCI-E x16 slot? You must have that power cable connected.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •