Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Windows 8.1 + Wake on Lan or Wake with keyboard/mouse = Problem !!!




  1. #1
    neodraig is offline Junior Member
    Join Date
    Mar 2014
    Location
    France
    Posts
    2

    Question Windows 8.1 + Wake on Lan or Wake with keyboard/mouse = Problem !!!

    Hi,
    I just built my new rig and I spend all the evening trying to configure the Wake on Lan, that was a real nightmare.
    With my previous computer (based on an Asrock AM3 motherboard with Windows 7) I just had to activate the option in the bios, use the MAC and IP address and that was it !!!

    With the Asrock Z87E-ITX and Windows 8.1 it's been a real ordeal to make things work (and I'm not even sure I did it the right way ).

    So the first thing I tried was to activate "Wake From Onboard Lan" in the UEFI then went into Windows to acces the Ethernet controller properties to enable it to be wake through magic packets, but the option was already activated in an Intel tab. I thought everything was ready, but sadly it didn't work.

    Then I tried the Intel Connect Technologie with Meshcentral, but that's just utter crap and it didn't work as well.

    In the UEFI I also tried to activate "Boot From Onboard LAN", but exept adding a new splash screen during the boot sequence, it didn't help at all.


    It's then that I noticed that waking my PC by pressing a key on the keyboard didn't work as well, though I had managed to have it work a few times.


    So I went on the net to gather some info, and I found that I should activate "PCI Devices Power On" instead of "Wake From Onboard Lan" (What is the "Wake From Onboard Lan" used for then?). But again that didn't work

    Then I thought it was because of the ultra fast boost in the UEFI settings, but that wasn't that either.

    What puzzled me is that WOL or wake with the keyboard would work when I would either choose "sleep" or "hibernate", but when I was just using "sutdown", it would never work

    So it made me think that the Haswell processors have a new sleep state, so it could be the reason of my problems. And while searching for information about that, I discovered the infamous "Hybrid Shutdown" of Windows 8. So I turned if off, and hallelujah, Wake on Lan or Wake with the keyboard was finally working.


    Now I wonder if it's a problem with my motherboard?
    Is it possible to have the WOL capability when at the same time having the Hybrud Shutdown" or (Ultra)"Fast boost" activated?

    Maybe I've done something wrong, after hours of trials and errors, deactivating the Hybrid Shutdown was the only way to make WOL work :-/

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Windows 8.1 + Wake on Lan or Wake with keyboard/mouse = Problem !!!

    Interesting information, thanks for posting it. You are not the first person to have WOL issues when using Windows 8 or 8.1 on mother boards that have an Intel network chip, like your board's I217V. I don't think there is a problem with your mother board related to WOL when using Windows 8.

    The Release Notes for the latest (as of 02/14/2014) version of the Intel network software compatible with the I217V, 19.0, contains the following about WOL:

    Under Microsoft Windows 8 or Windows Server 2012, the system may not wake even
    though Wake on LAN settings are enabled. Disabling Fast Startup in the
    operating system should resolve the issue.


    Link to this document:

    http://downloadmirror.intel.com/23071/eng/readme.txt

    That has been in the Release Notes for the Intel network driver for almost a year now. Which implies Intel has not yet, or cannot fix this issue, due to the way Windows 8 Fast Startup works.

    You mentioned Windows 8 Fast Startup, and Ultra Fast Boot, which are two different things. Windows 8 Fast Startup is enabled and works regardless of the Fast Boot setting (Fast or Ultra Fast), unless you disable it as you did.

    The Ultra Fast, Fast Boot setting is an option that works with a Windows 8 UEFI booting installation. I don't know if you have a UEFI booting Windows 8 installation, but again that is not what Windows 8 Fast Startup is.

    I found some more interesting information about Fast Startup, and a way to have it enabled, but perform a standard full Windows shutdown (that does not cause a Fast Startup to occur) if you want to do so. You may be able to use this technique to shutdown the PC if you plan on using WOL the next time the PC is started.

    A new option called "Full" was added to the shutdown command. From a cmd prompt, run: shutdown /s /full / t 0 to do an immediate full shutdown. That will cause a standard, non-Fast Startup on the next start of the PC. You can also do this by typing the Win + X keys, and choosing Shutdown.
    Last edited by parsec; 03-15-2014 at 11:44 AM.

  3. #3
    neodraig is offline Junior Member
    Join Date
    Mar 2014
    Location
    France
    Posts
    2

    Default Re: Windows 8.1 + Wake on Lan or Wake with keyboard/mouse = Problem !!!

    Thank you very much for taking the time to answer and for clarifying things.

    You are completly right about "Ultra fast Boot", I turned it on in the UEFI settings and WOL and keyboard wake up are working fine.
    I spent so many hours the other evening trying to make things work that I must have mixed up the settings.

    So the problem is really the "Hybrid Shutdown", but you say that it could be a compatibility problem with the Intel network chip. If it's really the case, shame on Intel as the problem as been known for more than a year and hasn't been fixed yet.

    But the other day I found that:
    "Wake on LAN" (WOL) behavior in Windows 8 and Windows 8.1

    So maybe it's not just the Intel chip the problem, but Windows 8.1 (but I'm no expert so I can't tell).

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Windows 8.1 + Wake on Lan or Wake with keyboard/mouse = Problem !!!

    You are welcome, I learned a thing or two researching this issue so well worth it to me.

    IMO, the issue is definitely a compatibility issue with Windows 8 Fast Startup and the Intel network driver, not the network chip itself.

    If we look at the difference between the usual system start up and the Windows 8 Fast Startup, we can see the probable source of the problem:

    Windows 8.1 + Wake on Lan or Wake with keyboard/mouse = Problem !!!-windows-8-fast-startup-jpg

    Microsoft describes the difference, in a very general way, like this:

    Another important thing to note about Windows 8’s fast startup mode is that, while we don’t do a full “Plug & Play” enumeration of all drivers, we still do initialize drivers in this mode. Those of you who like to cold boot in order to “freshen up” drivers and devices will be glad to know that is still effective in this new mode, even if not an identical process to a cold boot.

    My point is, Intel may not be able to do anything to the network driver that would overcome the difference between the initialization of the network chip when using Fast Startup. IMO, Microsoft wants us to believe there is no difference between the two start up types, but the statement, "we don’t do a full “Plug & Play” enumeration of all drivers", tells us that it is not identical.

    You have seen that disabling Fast Startup fixes the WOL issue, as Intel said. Given the way Windows 8 Fast Startup works, we may be lucky that we are not having more issues with other things besides the network chip.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •