Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: C2750D4I stability problems




  1. #11
    Join Date
    Apr 2014
    Location
    United Kingdom
    Posts
    5

    Default Re: C2750D4I stability problems

    I also have stability problems with this board.

    Same setup as phin

    Firmware 0.14.0 Bios 1.80
    Crucial 16GB Kit (8GBx2) DDR3L 1600MT/s (PC3-12800) DR x8 ECC UDIMM

    So far i have tried ubuntu server 12.04 / 14.0 and Centos 6.5.

    When i first got it i setup KvM and started to build some VM's I then spent around 2 weeks messing about with various server core 2012 installs and installing SQL server blahblahblah. No issues.

    So now i need to backup my VMDKs. Started to copy the vmdk went off to watch tv etc... 30 mins later still copying. So i booted webmin and it times out. Check the BMC logs and i get this:

    FRB2/Hang in POST Faliure - Asserted

    Long story short its completely hung. Thus begins my testing of the failures.

    I can reproduce this crash within 5-120 seconds every single time its easy.

    Mount an nfs share and then simply copy a large file from it to the local hdd.

    mount x.x.x.x:/export/nas nas/
    cp nas/somefile.ext somefile.ext

    Starts copying then just stops.

    I have noticed 2 things:

    Ubuntu dies on its ass. It is a complete hang, console hangs, keyboard unresponsive etc...

    CentOS is a different story on cent I start the copy via SSH and my direct login (i.e. logged into the machine itself) is still responsive i can press keys blinking cursor but... commands do nothing. CTRL+ALT+DEL does work but it hangs mid shutdown with:

    unable to umount nas share is busy (i am paraphrasing here cant remember the EXACT wording).

    I haven't tried applying the bios again just in case.
    I refuse point blank to switch of cstate cpu options etc... because quite frankly i did not purchase partial use of the board and those aren't my problem to solve.
    I CAN copy the vmdk's as many times as i want to and from the local HDD. In fact i created 350 gb of these files just for ****s and giggles.

    So in my random testings i encountered the following error which it appears is the cause of my problems (i dont suppose it is all problems - it is mine though - and you wont get this error in ubuntu it just folds like a pack of cards).

    igb 0000:07:00.0 Detected Tx Unit Hang
    igb 0000:07:00.0 Eth0 Adapter Reset

    I am convinced the problem is the i210 drivers in the linux kernels.

    Next stop is to install server 2012 (non R2) and the drivers from the asrock website. This is tonights mission but since i have to spend time with the wife and the baby probably more likely to be the weekend :)
    Last edited by larch; 04-24-2014 at 04:08 AM.

  2. #12
    Join Date
    Apr 2014
    Location
    United Kingdom
    Posts
    5

    Default Re: C2750D4I stability problems

    So Server 2012 (non r2) installed network cards do not automatically work so you need the drivers from ASRocks website. With these i managed to copy 20gb or so before the network went down, interestingly server 2012 did not hang it just lost the network.

    I flashed the bios with 1.8 again.

    Same as above.

    I updated the drivers to the latest april ones from intels website.

    Same as above.

    One thing of note from windows i am being spammed in the event log (every second) by:

    Component: PCI Express Root Port
    Error Source: Advanced Error Reporting (PCI Express)

    Bus:Device:Function: 0x0:0x3:0x0
    Vendor ID:Device ID: 0x8086:0x1f12
    Class Code: 0x30400

  3. #13
    Join Date
    Apr 2014
    Location
    California
    Posts
    3

    Default Re: C2750D4I stability problems

    I ended up returning the board because of these problems. You may want to try testing with memtest86. It runs without any OS so it is a much cleaner test. In my case it locked up within a few minutes of running very reliably.

  4. #14
    Join Date
    Apr 2014
    Location
    United Kingdom
    Posts
    5

    Default Re: C2750D4I stability problems

    12 hours memtest 86 no errors.

    Caving in and disabling speedstep i was able to copy 350gb worth of vmdk files (the same 50gb file 7 times) to and from my nas. Did this 3 times for over 1 tb and never had an issue.

    Reenabled speedstep got the crashing back within 2 gb

  5. #15
    Join Date
    Apr 2014
    Location
    United Kingdom
    Posts
    5

    Default Re: C2750D4I stability problems

    So with speedstep and c-states off this board is 100% stable except...


    # dd if=/dev/zero of=nas/downloads/testfile.bin bs=1M count=1000 conv=fsync
    1000+0 records in
    1000+0 records out
    1048576000 bytes (1.0 GB) copied, 15.028 s, 69.8 MB/s

    dd if=/dev/zero of=/tmp/testfile.bin bs=1M count=1000 conv=fsync
    1000+0 records in
    1000+0 records out
    1048576000 bytes (1.0 GB) copied, 7.42082 s, 141 MB/s

    dd if=nas/downloads/testfile.bin of=/dev/null bs=1M
    1000+0 records in
    1000+0 records out
    1048576000 bytes (1.0 GB) copied, 108.679 s, 9.6 MB/s



    Basically the 'nas' i am copying from is the box i want to replace (old e8400 with some caviar greens - reds were not available 4/5 years ago).

    I have tried :

    CentOS with and without ElRepo i210 drivers
    Ubuntu 12 and 14
    Winblows 2012 and r2

    All have the except same issue. Incoming network speed is terrible sometimes i can see it climb to 700 even 900 mbits via nload but it kinda bounces around then drops to 80 again.

    Outgoing network speed is exactly as i expect 990 mbits and consistent.

    I have tried this in my routers gb switch (rt-ac68u) an old dlink web smart gb switch and my current procurve 1810-24g v2 (the v2 is gb version).

  6. #16
    Join Date
    Sep 2014
    Location
    Singapore
    Posts
    5

    Default Re: C2750D4I stability problems

    OS : freebsd 10
    RAM : kingston non ECC 2 * 8GB
    zpool : 6 * 3TB WD Red

    I did dd test for 10GB file, no issue
    also, copied 450GB files from local disk ( OS disk ) to zpool, no issue.
    Attached Images Attached Images C2750D4I stability problems-img_90900447723356-jpeg 

  7. #17
    Join Date
    Sep 2014
    Location
    Singapore
    Posts
    5

    Default Re: C2750D4I stability problems

    guy. i did a test using iperf .

    My NIC died at 14051 second and each second transfer 114-155MB
    i'm successfully transfer the 14051 * 114MB = 1564GB data thru network.

    I login to console ( no hung ) and restart the freebsd netif service, the network connectivity is back again.

    C2750D4I stability problems-screen-shot-2014-09-24-2-53-30-am-png

  8. #18
    Join Date
    Apr 2014
    Location
    United Kingdom
    Posts
    5

    Default Re: C2750D4I stability problems

    Just FYI in the end I RMA'd the board and the Rev 1.1 they sent back is totally stable even with speedstep etc switched on.

    Much much better.

  9. #19
    Join Date
    Jan 2014
    Location
    California, USA
    Posts
    91

    Default Re: C2750D4I stability problems

    Good to know. Thanks for the update!

  10. #20
    Join Date
    Nov 2014
    Location
    Denmark
    Posts
    29

    Default Re: C2750D4I stability problems

    Quote Originally Posted by larch View Post
    Just FYI in the end I RMA'd the board and the Rev 1.1 they sent back is totally stable even with speedstep etc switched on.

    Much much better.
    larch, was that Revision 1.1 or 1.01? - I recently received my board, and the PCB version is 1.01, but with BIOS P1.50 and BMC FW 0.19.0.
    Just curious

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 4 users browsing this thread. (0 members and 4 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •