Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Asrock Z87E-ITX Faulty?




  1. #1
    Join Date
    Jan 2014
    Location
    Scotland
    Posts
    8

    Default Asrock Z87E-ITX Faulty?

    Last night while I was using my media PC it suddenly & without warning powered off. I was unable to get the PC to boot. I noticed that the rear usb ports were still receiving power as my mobile phone was charging. So it would appear that my Silverstone Strider ST45SF-G 450W PSUwas OK.

    I removed everything from the motherboard, case & rebuilt, still nothing. Tried individual sticks of RAM - nothing. Temperatures were OK, BIOS reported early 50oC for CPU temp when I built the system earlier in the week

    My gut feeling is that the motherboard, which is only a matter of days old just died on me.

    Any thoughts on this?

    CPU is an i5 4400 84w Haswell
    2 x 4GB Samsung Green DDR3
    Last edited by AlistairS; 03-16-2014 at 03:24 AM.
    Asrock Z87E-ITX, Intel i5 4400 Haswell, 2 x 4GB Samsung Green DDR3,Silverstone Strider ST45SF-G 450W PSU, Silverstone Raven RVZ01 128GB Samsung mSATA SSD

  2. #2
    Join Date
    Jan 2014
    Location
    Scotland
    Posts
    8

    Default Re: Asrock Z87E-ITX Faulty?

    nevermind, solved it myself. Faulty motherboard replaced by amazon. Everything up & running OK
    Asrock Z87E-ITX, Intel i5 4400 Haswell, 2 x 4GB Samsung Green DDR3,Silverstone Strider ST45SF-G 450W PSU, Silverstone Raven RVZ01 128GB Samsung mSATA SSD

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •