This is related to http://forums.tweaktown.com/asrock/5...75-pro4-m.html

Windows 7 Pro 64
A75 Pro4-M
AMD A6-3500 K12 bridge. Chipset Revision 00
AHCI mode
USB Driver host controller - AMD 1.1.0.140 11/28/2012 amdxhc.sys and usbfilter.sys
USB Hub - AMD 1.1.0.140 11/28/2012 amdhub30.sys

The link above was basically a new Thermaltake USB HD dock not working in USB 3. I uninstalled fastusb (whatever it's called) and updated the chipset drivers and the dock began working.

I am having several problems with the dock, again, and I *assume* it is due to the USB 3 drivers because it works fine in USB 2.
Problems:

I will say that once the U3/dock started working I was able to copy a massive amount of data on to the dock/drive w/no problem at all. 1 900mb folder copied just by itself...it worked great.

- If I plug the dock into any U3 port besides the only one I've ever used it in I get the 'format disk first' message. This was the msg rec'd prior to Fastusb removal and updating of chipset drivers. To be clear, If plug it into the original U3 port it will connect and if I plug it into any U2 port the dock/drive work fine.

-Copying files simply does not work. If I copy from the dock/drive to an internal HD, or vice versa, the same thing happens. It will copy at 120-140 Mb/s and then I will get 'the destination specified does not exist'. The folder for the dock/drive disappears and then the dock/drive will start cranking and Autoplay for the dock/drive will pop up. Note: I've only tried this w/relatively large files; 70Mb and bigger.

Problem seems to be related to USB 3.