Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Z87 killer sata controller problem with my OCZ Vertex 2 OCZSSD2-2VTX50G. It doesn't detect unless I power on and off a few times.




  1. #1
    Join Date
    May 2014
    Location
    New York
    Posts
    1

    Default Z87 killer sata controller problem with my OCZ Vertex 2 OCZSSD2-2VTX50G. It doesn't detect unless I power on and off a few times.

    Set my bios default and still having trouble booting up. It doesn't recognize my SSD drive (AHCI) but it detect my normal HDD. I had to hold the power then I can boot into windows.

    I posted this on Newegg motherboard review I got this..

    Dear ASRock Customer

    Thank you for your purchase and review.
    This issue usually related to the compatibility between Intel 8 series chipset and SandForce old controller.
    If possible, please test with either HDD or SSD with new controller to check if the symptom still occurs.
    If you have any technical issues please contact us at ASRock > Support Request Form. We will assist you shortly.

    Thank you

    ASRock SUPPORT
    [COLOR=#4D4D4D][FONT=helvetica]Tech Support Email: ASRock > Support Request Form



    What new controller? My old ASROCK motherboard works fine with this SSD just not this motherboard.

    How can I fix it? I just want to use it in the morning without booting up 3 times in order to get into Windows! I don't have time for it.
    Last edited by enyceckk; 05-08-2014 at 07:22 AM.

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z87 killer sata controller problem with my OCZ Vertex 2 OCZSSD2-2VTX50G. It doesn't detect unless I power on and off a few times.

    Quote Originally Posted by enyceckk View Post
    Set my bios default and still having trouble booting up. It doesn't recognize my SSD drive (AHCI) but it detect my normal HDD. I had to hold the power then I can boot into windows.

    I posted this on Newegg motherboard review I got this..

    Dear ASRock Customer

    Thank you for your purchase and review.
    This issue usually related to the compatibility between Intel 8 series chipset and SandForce old controller.
    If possible, please test with either HDD or SSD with new controller to check if the symptom still occurs.
    If you have any technical issues please contact us at ASRock > Support Request Form. We will assist you shortly.

    Thank you

    ASRock SUPPORT
    [COLOR=#4D4D4D][FONT=helvetica]Tech Support Email: ASRock > Support Request Form



    What new controller? My old ASROCK motherboard works fine with this SSD just not this motherboard.

    How can I fix it? I just want to use it in the morning without booting up 3 times in order to get into Windows! I don't have time for it.
    Sorry to say, this problem cannot be fixed. The SATA controller in the Z87 chipset is not compatible with any SSD that uses the early SandForce 1200 and 1500 series SSD controllers, like the Vertex 2.

    OCZ has information about this, here: Guide Vertex 2 - Agility 2 and Haswell

    It seems these SandForce controllers only meet an early SATA specification, or were casual about meeting those specs. Meanwhile, the SATA specifications have continued to advance and the Intel 8 series chipsets are a transition that are more strict about the SATA specs. Intel does not create the SATA specifications, that is done by the SATA organization itself.

    When ASRock said, "... please test with either HDD or SSD with new controller", they are referring to the controller in SSD itself. This means a newer model SSD that does not use the older Sandforce controllers, which have not been used for a while now.

    ASRock is suggesting this as a test to determine if the issue is the board or the SSD. But in your case the problem is the SSD. You are not the first person to have this problem. Frankly, you are lucky to get your Vertex 2 working at all with a Z87 board.

  3. #3
    Join Date
    May 2014
    Location
    USA
    Posts
    1

    Default Re: Z87 killer sata controller problem with my OCZ Vertex 2 OCZSSD2-2VTX50G. It doesn't detect unless I power on and off a few times.

    I had the same problem with my Adata S599 60GB, it has the SF-1200 controller I believe. It sucked too, because when I bought it in January I couldn't find any information around the webz regarding this z87 chipset incompatibility. After an entire day of pulling my hair apart, flashing the bios, reinstalled windows 7 in UEFI mode, nothing changed the fact that the bios was detecting the drive once every ten times I turned it on. Finally found one obscure post, where someone said "New haswel chipsets don't support some SF controllers." I bet now you can google "OCZ Agilty 2 Z87 chipset problem" and get a million results.

    I think its dumb and probably a conspiracy but I won't dump that baggage on you.... Be glad you didn't waste a day and a half trying to figure it out yourself and use it as an excuse to buy a fancy new SSD. For your Agility 2, use it to upgrade another computer you own, or do what I did and buy one of these: http://amzn.com/B00FCLG65U. I get pretty good speeds out of it as long as I have it plugged into a usb 3 slot. (~150mb/s) Not sure if it goes without saying, but the drive works just fine with my z87 once I put it in the usb enclosure.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •