Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: PS/2 keyboard not working during Boot Manager screen




  1. #1
    hottroc is offline Junior Member
    Join Date
    Jun 2014
    Location
    UK
    Posts
    8

    Default PS/2 keyboard not working during Boot Manager screen

    Hi,

    A strange keyboard problem.....

    When I boot up, my PS2 keyboard works and I can press F2 to get to the UEFI bios. The keyboard works within the UEFI BIOS to navigate and select etc.
    Then later (or if I don't press F2) during the Windows Boot Manager stage the keyboard does NOT work and I have to wait 30seconds for the default timeout. It also does NOT work during Windows Error Recovery, meaning I would be unable to select Safe Mode if necessary.
    ....then once Windows starts the keyboard works again, and is fine throughout the normal Windows use.

    Why does it not work during the Boot Manager phase and how do I fix it?

    The keyboard worked fine with my old (Asrock) motherboard including at the Boot Manager stage. It also worked with this motherboard at first, but then I did some updates from the Asrock site and I think a INF or BIOS update may have changed something.
    Another possibility is that I also changed my mouse around the same time and Microsoft update then installed what I thought was the mouse software (it's a MS USB mouse), but turned out to be Mouse and Keyboard software which seemed to wipe out my Intellitype. I've tried uninstalling it and reinstalling the Intellitype but the problem remains.

    Any suggestions welcome as long as they are not to get a different keyboard. I like this one and as I said I'm pretty sure it's not the keyboard itself at fault.

    EDIT - OK just to test, I borrowed a different PS/2 keyboard (different make and model)....and the result was exactly the same. Works in Windows but not in (real-mode?). I think the next stages are either repair of Windows or reverting to older BIOS, INF or ME. Which of these is responsible for devices during the Boot Mgr phase (that's real-mode right?).

    Thanks,
    hottroc
    PS I had to update the BIOS to support 4th gen processor.

    Asrock H87M
    Intel i5
    Bios 2.20
    Windows 7 64-bit
    Last edited by hottroc; 06-24-2014 at 07:17 PM. Reason: Tested with another keyboard

  2. #2
    hottroc is offline Junior Member
    Join Date
    Jun 2014
    Location
    UK
    Posts
    8

    Default Re: PS/2 keyboard not working during Boot Manager screen

    Well, a bit disappointed to have no replies after over 200+ views.

    However, after much reading of many similar topics where people have had similar keyboard problems with other Asrock mboards, and lots of subsequent trial and error changes, I have discovered that if I set Legacy USB Support to Disabled then my keyboard becomes fully functional again, ie the problem disappears.

    I'm surprised because we are talking about a PS/2 keyboard not USB.

    Anyway I don't really know what this Legacy USB Support setting does?
    Can someone advise a) What counts as a Legacy OS b) Why the setting effects PS/2 keyboard c) What the setting does (in detail) and what other devices would/should/does it effect how and when?

    Finally, is there a BIOS update on the horizon to fix this? Or is there another way to fix the problem (maybe editing the Registry to load a keyboard driver or something) without other side effects?

    Thanks in advance for any help or info.

  3. #3
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: PS/2 keyboard not working during Boot Manager screen

    Welcome to the forum.

    A web search using: what is usb legacy support might provide some helpful information.

    I think that it has to do with enabling or disabling additional checking for older usb 1.1 compatibility while posting and booting.

    I've seen reports that say that with usb legacy support disabled, it eliminates some problems when overclocking and testing with LGA775 systems.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  4. #4
    hottroc is offline Junior Member
    Join Date
    Jun 2014
    Location
    UK
    Posts
    8

    Default Re: PS/2 keyboard not working during Boot Manager screen

    Thanks for the response. I read some of the links from the search you suggested. Although I understand the words they say it still doesn't make sense in the context of MY issue and leaves several gaps in knowledge. And there is also a variety of interpretations as to the function of the setting......

    Some talk about support for USB devices in OS's (or OS context environments) without USB support, others about supporting old 1.1 USB devices..... so which is it, or is it both?

    Secondly all the references are talking about USB devices, NOT PS/2 so why is it applying to my problem.

    Also I read that "USB 2.0 is forward and backward compatable with USB 1.1. You can use 1.1 devices in a 2.0 port, it just won't run at 2.0 speed, it'll revert to the 12Mbps max of USB 1.1." so why if my device (keyboard) was effected by the setting why did it just not still work, even if a little slower?

    And finally why is it that DISABLING the setting has improved my situation? It is supposed to help not hinder.
    Just to note also that setting to "Auto" did NOT improve my situation. Why not? What does Auto actually do?

    I'm also wondering what the setting does to my Asrock board in more detail than I can find so far. What specifically does it do? ("provide support" is NOT really what I'm looking for)
    Some references have said that USB devices will not work outside of Windows if the setting is Disabled (yet my USB mouse seems OK! - ***EDIT, oh no it doesn't, see edit below***) which is worrying.

    The most important thing I'm hoping for is that disabling the option will not stop my external HDD from working when I'm trying to image my drive (which is an "external-to-windows" operation if you know what I mean) as this is my primary backup method. I won't know until I try.

    And also,..... is this the expected behaviour or is this a bug in the BIOS? And will there be a fix, ie updated BIOS, from Asrock to cure it?
    IMHO it's a bug, cos I need my PS/2 keyboard and USB devices, both, enabled in all situations which is presumably the purpose of the feature.

    One other thing not explained elsewhere is why the keyboard worked before (ie prior to my BIOS or INF update or whatever)?

    EDIT - Oh, so after a reboot I went into BIOS again and realised this time my USB mouse is not working in the BIOS! Great. So it seems you can have PS/2 OR USB but not both! Great! Shame that they didn't think of that when they (along with other mboard manufacturers) decided to only include one PS/2 port, else I could have continued using my PS/2 mouse that I had to swap. This deffo must be a bug. Come on Asrock please provide an update to fix this, as it worked previously, so something you changed recently in the BIOS or INF code?
    Last edited by hottroc; 06-27-2014 at 12:02 AM.

  5. #5
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: PS/2 keyboard not working during Boot Manager screen

    from Download Microsoft IntelliType Pro 8.2 Keyboard Software for Windows - 64 bit from Official Microsoft Download Center:
    With IntelliType Pro 8.2, setup automatically detects your keyboard model. If you have more than one keyboard attached to your computer, each keyboard model can have different settings. PS/2 devices are no longer supported in IntelliType Pro 8.2.
    The following information is from my Gigabyte P35 user manual:
    Legacy USB storage detect

    Determines whether to detect USB storage devices, including USB flash drives and USB hard Drives during the POST. (Default: Enabled)
    It makes sense to me that our systems will POST faster with this setting disabled.
    I would be very surprised if usb drives would NOT work with this setting disabled once we are in windows.
    If you want to flash the bios from a usb drive before starting windows, this setting will need to be enabled.

    You can also contact ASRock tech support using this online form: ASRock > Support Request Form

    Let us know if you find any additional information.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  6. #6
    hottroc is offline Junior Member
    Join Date
    Jun 2014
    Location
    UK
    Posts
    8

    Default Re: PS/2 keyboard not working during Boot Manager screen

    Quote Originally Posted by profJim View Post
    PS/2 devices are no longer supported in IntelliType Pro 8.2.


    No, but I'm using version 7.1 of Intellitype Pro (64-bit version) which DOES support PS/2 devices and my keyboard. It's what I have been using with this keyboard for an eternity so I know it is not the issue.


    I would be very surprised if usb drives would NOT work with this setting disabled once we are in windows.
    Once in Windows has never been the problem.

    If you want to flash the bios from a usb drive before starting windows, this setting will need to be enabled.
    Yes and there are plenty of other instances where this will be a PITA. This needs fixing.

    You can also contact ASRock tech support using this online form: ASRock > Support Request Form
    My first port of call. Their responses so far, with about 3 days between each, have been suggestions of things I've already tried such as "try with a USB keyboard" etc. Er that's not the point, it should work with a PS/2 keyboard, AND I don't have a USB keyboard anyway. Let's hope they eventually find a solution.

    Let us know if you find any additional information.
    I'm hoping they will help me with a BIOS fix, I can't see there being any other solution.

  7. #7
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: PS/2 keyboard not working during Boot Manager screen

    I doubt that any motherboard manufacturer would make the time to code and test a fixed bios version for "older" motherboards unless they found that there was a very serious problem. Maybe they already have an "unpublished" beta bios that might work.

    Send a private message to ASRock TSD - Emily include a link to this thread and ask her to reply in your thread.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  8. #8
    hottroc is offline Junior Member
    Join Date
    Jun 2014
    Location
    UK
    Posts
    8

    Default Re: PS/2 keyboard not working during Boot Manager screen

    OK, thanks for the advice, hopefully Emily will be able to help. It is an older keyboard but has always been fine as a Standard PS/2 keyboard, and the fact that this also happens with another keyboard (not so old) makes me think this is a general PS/2 port problem with the specific BIOS version rather than specific keyboard.

    I don't mind a Beta BIOS if that's what it takes.

    EDIT, Just to add, remember this was working with this same board before I updated the BIOS (assuming that's the culprit). So Asrock were already supporting the keyboard on this motherboard! Also it could be argued that with the setting disabled and the keyboard working it is the modern USB mouse that isn't being supported! I'd also remind you that, with USB Legacy Support on Auto both the keyboard AND mouse are working in the BIOS stage at the same time. So whatever drivers are in use then are supporting both devices. Just needs loading at the next stage!
    Last edited by hottroc; 07-03-2014 at 03:18 PM. Reason: See EDIT section

  9. #9
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: PS/2 keyboard not working during Boot Manager screen

    You're welcome.

    We need detailed information about ALL OF THE HARDWARE in your system.

    We can best help you after you create a detailed hardware list in the System Specs
    portion of your forum profile at the bottom of the profile page or in your forum signature.
    Be sure to include brand names and model numbers.
    When you are done editing or creating your hardware list, save the settings.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  10. #10
    hottroc is offline Junior Member
    Join Date
    Jun 2014
    Location
    UK
    Posts
    8

    Default Re: PS/2 keyboard not working during Boot Manager screen

    Oh, I thought I already did that when I signed up, but it appears to have gone missing, so I've saved it again.

    I'm awaiting a reply from Emily.
    Last edited by hottroc; 06-30-2014 at 03:16 AM.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •