Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: h87m pro4 wol with linux




  1. #1
    Join Date
    May 2014
    Location
    earth
    Posts
    4

    Default h87m pro4 wol with linux

    Hi,

    Is there a way to activate WOL from linux? I saw that you have to install the latest nic driver to get wol to work . . . so does that mean I have to install windows? I don't mind doing that if I can activate WOL (have it persist) and then re-install linux.

    please advise.

    Thanks.

  2. #2
    guidugli is offline Junior Member
    Join Date
    Jan 2014
    Location
    Brazil
    Posts
    20

    Default Re: h87m pro4 wol with linux

    Asrock Z87 Fatal1ty Professional, i7 4770, G Skill Ares 32GB, ATI Radeon R9 290, WD Velociraptor 300GB, WD Black 500GB, 2 WD Green 2TB, 1 WD Green 1 TB, Antec Signature 850W, CoolerMaster CM 690 II Case, Fedora Linux / Windows (virtual machine with GPU pass-through)

  3. #3
    Join Date
    May 2014
    Location
    earth
    Posts
    4

    Default Re: h87m pro4 wol with linux

    Quote Originally Posted by guidugli View Post



    Thanks the articles give me hope. I've activated WOL in the BIOS and ethtool reports "Wake-on: g" but WOL doesn't work.
    I know the WOL tool I'm using works because it's able to wake other PCs. Any other thoughts on what else I should try?


    I'm running esxi 5.5 u1 and I'm wondering if the issue might be the driver I'm using (google didn't show anything one way or the other.)
    This is the driver:
    http://www.virten.net/files/net-e1000e-2.3.2.x86_64.vib (SHA1: 0d184bd8b9db15979231b9972c321e9b30404e7e)


    Thanks!




    ~ # ethtool vmnic0
    Settings for vmnic0:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 2
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000007 (7)
    Link detected: yes

  4. #4
    guidugli is offline Junior Member
    Join Date
    Jan 2014
    Location
    Brazil
    Posts
    20

    Default Re: h87m pro4 wol with linux

    Sorry, my experience is very limited with WOL. I was hoping that the tutorials would be able to solve your problem. I don't know if driver is really the key factor here since the PC is usually shurdown or in a sleep state. IMO, Your BIOS should be able to interpret the WOL signal and power on the PC.
    Last edited by guidugli; 07-04-2014 at 03:47 AM.
    Asrock Z87 Fatal1ty Professional, i7 4770, G Skill Ares 32GB, ATI Radeon R9 290, WD Velociraptor 300GB, WD Black 500GB, 2 WD Green 2TB, 1 WD Green 1 TB, Antec Signature 850W, CoolerMaster CM 690 II Case, Fedora Linux / Windows (virtual machine with GPU pass-through)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •