Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Intel extreme tuning utility




  1. #1
    Joe-912's Avatar
    Joe-912 is offline Member
    Join Date
    Feb 2013
    Location
    UK
    Posts
    197

    Default Intel extreme tuning utility

    Hi all, any of you used Intel extreme tuning utility? I've been messing around with it for few months, you supposed to be able to tune the memory if you have xmp profiles which my Kingston memory has, but nothing shows up in the interface, only system information within the program, I am using the xmp profile 1600 via bios
    any ideas?

    Still can't upload images!
    Thanks
    Joe
    Asus Maximus 7 Hero > Corsair Obsidian 750d Airflow > Intel 4790K > Noctua NH-D15 > 16GB G-skill Sniper 2133 > Samsung SM951 256GB > Sandisk X400 512GB > Western digital black Sata 6 500GB > Western digital black 640GB > Windows 10 Pro 64 > Asus 27" MX279H Monitor > Gibabyte GTX 980Ti extreme

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Intel extreme tuning utility

    No images for you too, that seems to break every now and then in this forum, I couldn't upload any on 7/26/2014, and today too.

    In the past, mother boards had to be compatible with IXTU in order for it to work correctly. I don't know if that is still true, I'm just glad that IXTU works as much as it does with my ASRock Z87 and Z97 boards.

    Certain things aren't available in IXTU, like CPU Input Voltage (Haswell boards only), and I can't tune my memory in IXTU either. If there is a fix for this, I don't know.

  3. #3
    Joe-912's Avatar
    Joe-912 is offline Member
    Join Date
    Feb 2013
    Location
    UK
    Posts
    197

    Default Re: Intel extreme tuning utility

    Thanks for reply, Yes I watched a few reviews on youtube regarding IXTU and see some people the memory config shows up, another thing I noticed was when benchmarking and uploading results it says my memory is running at 1333 and not 1600, I know it's running at 1600 because I use the xmp profile and just back the memory voltage off to 1.5v instead of the 1.6v on the xmp setting.
    all in all I quite like the IXTU suite.
    Have a great day ahead!
    Joe
    Asus Maximus 7 Hero > Corsair Obsidian 750d Airflow > Intel 4790K > Noctua NH-D15 > 16GB G-skill Sniper 2133 > Samsung SM951 256GB > Sandisk X400 512GB > Western digital black Sata 6 500GB > Western digital black 640GB > Windows 10 Pro 64 > Asus 27" MX279H Monitor > Gibabyte GTX 980Ti extreme

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •