Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Windows 7 64bit Clean install will not see Hard Drive




  1. #1
    Join Date
    Jul 2014
    Location
    uk
    Posts
    3

    Default Windows 7 64bit Clean install will not see Hard Drive

    Hi,
    I have just purchased components for 5 new PCs. This is what I have. ASRock FM2A55M-VG3+ Motherboards, 500gb Seagate hard discs and 3.9GHz AMD A6 CPUs.

    I am having an issue on these machines where the Windows 7 install does not detect the hard discs. I tried a windows 8 install and that detects the drive OK. The Motherboard spec says it supports Windows 7 HP.

    This must be a driver issue but I have tried all the Sata drivers I can find for Win7 64Bit that I can find on the driver CD with no luck.

    I am considering returning these Motherboards and going for another manufacturer.

    Any Ideas?

    TIA

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Windows 7 64bit Clean install will not see Hard Drive

    That's strange, so on the same board and HDD, the Win 7 installer cannot see the HDD, but Win 8 does, correct?

    The HDD is recognized in the BIOS regardless of the Win installer? Did you configure anything in the SATA configuration options? What SATA mode are you using?

    The Win 8 installer working while the Win 7 installer failing implies a driver compatibility problem. Win 8 has a different AHCI driver than Win 7 (apparently) but both are said to have the same compatibility. Unless you are using RAID mode, you should not need to install a SATA driver.

    The AMD All-In-One driver package and the AMD SATA "floppy" RAID driver versions are identical for Win 7 and Win 8 according to the ASRock page for your board.

    Your board has been available for nine months, and we aren't seeing any threads in this forum about this problem AFAIK.

  3. #3
    Join Date
    Jul 2014
    Location
    uk
    Posts
    3

    Default Re: Windows 7 64bit Clean install will not see Hard Drive

    Yes that's correct. I have assembled 3 of these machines and they are all the same. A windows 8 install sees the drive but windows 7 doesn't. I am using standard off the shelf Windows 7 SP1 OEM discs.

    The BIOS can see the drive and optical fine

    I have tried setting the Sata storage to AHCI mode and also IDE mode and that's still the same.

    I would be starting to think it was a faulty board but I cant believe its 3 faulty boards. Its definitely a driver issue.

    I have tried contacting ASRock support but they are very quiet or very slow in replying.

    I am going to have to replace these boards with different ones I just don't like to be beaten.

  4. #4
    Join Date
    Jul 2014
    Location
    uk
    Posts
    3

    Default Re: Windows 7 64bit Clean install will not see Hard Drive

    A new day and starting a fresh.

    I tried a Win 7 Pro install and that found the drive OK so I did the Win 7 Pro install until it found the drive. I then restarted with the Win 7 HP disk and went through the install. The driver was still loaded for the drive so I deleted the 2 partitions that Windows 7 Pro install had created and continued with the Windows 7 HP install.

    Everything is now going fine.

    Cheers, mcoops

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •