Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: z77 extreme4 doesnt detect r9 270x




  1. #1
    Join Date
    Jul 2014
    Location
    usa
    Posts
    2

    Default z77 extreme4 doesnt detect r9 270x

    Hi,

    I am not sure what to do at this point except maybe buy a different graphic card. I ordered Amazon.com: Sapphire Radeon R9 270X 4GB GDDR5 DVI-I/DVI-D/HDMI/DP Dual-X with Boost and OC version PCI-Express Graphics Card 11217-04-20G: Computers & Accessories and I got a replacement. Both cards when plugged in gave me no signal on my monitor. I tried using clear cmos, which didn't work. I also tried upgrading my bios from P2.90 to the latest version which didn't work either and windows still wouldn't detect my r9 270x.

    Is this problem occurring to every owner of z77 mb and those that bought the r9 270x graphic card?



    Specs for my computer are:
    Operating System
    Microsoft Windows 7 Ultimate 64-bit SP1
    CPU
    Intel Core i5 3570K @ 3.40GHz
    RAM
    8.00 GB Single-Channel DDR3 @ 325MHz (9-9-9-24)
    Motherboard
    ASRock Z77 Extreme4 (CPUSocket)
    Graphics
    LC-32G90V (1360x768@59Hz)
    Intel HD Graphics 4000
    Hard Drives
    466GB Seagate ST500DM002-1BD142 ATA Device (SATA)
    PSU = Antec High Current Gamer Series HCG-900 ATX12V v2.3 / EPS12V v2.91 SLI 80 PLUS BRONZE Power Supply - Newegg.com

  2. #2
    Joe-912's Avatar
    Joe-912 is offline Member
    Join Date
    Feb 2013
    Location
    UK
    Posts
    197

    Default Re: z77 extreme4 doesnt detect r9 270x

    I take it you set the primary graphics in bios to pci?
    can't be that simple, but worth a shot ...
    Asus Maximus 7 Hero > Corsair Obsidian 750d Airflow > Intel 4790K > Noctua NH-D15 > 16GB G-skill Sniper 2133 > Samsung SM951 256GB > Sandisk X400 512GB > Western digital black Sata 6 500GB > Western digital black 640GB > Windows 10 Pro 64 > Asus 27" MX279H Monitor > Gibabyte GTX 980Ti extreme

  3. #3
    Join Date
    Jul 2014
    Location
    usa
    Posts
    2

    Default Re: z77 extreme4 doesnt detect r9 270x

    Primary Graphic Adaptor is PCI Express
    I disabled the IGPU multimonitor and my display gets no signal at boot.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •