Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 10 of 10

Thread: asrock fatal1ty z97x killer - black screen when not using onboard graphics card




  1. #1
    Join Date
    Aug 2014
    Location
    Germany
    Posts
    8

    Default asrock fatal1ty z97x killer - black screen when not using onboard graphics card

    hey guys,

    i bought a new mainbord, the asrock fatal1ty z97x killer. but everytime i try to use not the onboard graphics card but my msi sapphire r9 270x i got a black screen right away from the beginning when i press the power button. when i insert the r9 270x neither the onbord nor the 270x works.

    i'm pretty sure that my graphics card is not broken (it has worked before and it still does).For example: in the case when i randomly set the 'Video OpRAM' to 'UEFI only' in the CSM options, the r9 270x seems to work, letting me enter the uefi. but using these uefi settings does not allow me to start windows, because it looks like i can't boot from my ssd under these conditions.
    this is why i this that i use wrong uefi settings.

    any ideas what i could change or test? i would be very thankful!
    Last edited by seakyou; 08-20-2014 at 11:30 PM.

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: asrock fatal1ty z97x killer - black screen when not using onboard graphics card

    First, don't use any of the CSM options, just have CSM enabled and the other three options at their default settings. Those options are difficult to use, might not work right, and require a special kind of Windows installation.

    When you use your R9 270x, you must select the video card in the Chipset Configuration screen in the UEFI/BIOS. Set Primary Graphics Adapter to PCI Express when using a video card. Normally when a video card is put in a board, it will change to PCI Express automatically, but if the onboard graphics is still connected to a monitor, it might not switch by itself.

    Try this, with the video card in the PC, and the PC off and not connected to power, clear the BIOS/CMOS. You must use the internal jumper on the board to do that. Don't connect any cables to the onboard graphics. Then when you start the PC afterwards, go into the BIOS, set any settings you use, and check that the Primary Graphics Adapter is set to PCI Express. Then save and exit, and see what happens.

    Sometimes ASRock boards have video card compatibility issues, but your board is new and should be fine.

    Do you know what BIOS version you are using? I don't think that would make a difference, just wondering.

  3. #3
    Join Date
    Aug 2014
    Location
    Germany
    Posts
    8

    Default Re: asrock fatal1ty z97x killer - black screen when not using onboard graphics card

    hey,

    thanks man, you really made my day! so you seem to be right about the CSM Thing, that i should deactivate it. but i couldnt do it exactly the way you discribed. the Thing with the Jumper just wouldnt work. this is what i had to do:

    -start pc without my graphics Card
    -go into uefi Setting and deactivate CSM
    -then plug in graphics Card and connect it with the tv
    -insert bootable usb device
    -start pc and
    - reinstall Windows 8.1 64bit

    ... Installation still running. i hope everything is alright now

    again, i really appreciate your help!

  4. #4
    Join Date
    Aug 2014
    Location
    Germany
    Posts
    8

    Default Re: asrock fatal1ty z97x killer - black screen when not using onboard graphics card

    ok i got the next Problem. while updating win 8.1 64bit i got a White Screen and everything stops working. so i restarted the Computer and now i can see the System booting up but at that time it should Show the Windows sign i got a black Screen again . any ideas?

    update:
    reinstalled Windows and just updatded the graphics Card Driver. same result. ****. any ideas?
    Last edited by seakyou; 08-22-2014 at 07:08 AM.

  5. #5
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: asrock fatal1ty z97x killer - black screen when not using onboard graphics card

    So it sounds like you are able to install Windows 8.1 fine, but when you install the latest graphics driver for your card, then you have problems, right?

    Or said another way, you installed Windows 8.1, which completed, but then during the update process for Windows, drivers, etc, then you get the problem, correct?

    If that is right, this is an example of why I hate Windows automatic update, mostly on new installations of Windows. It doesn't do things in the correct order, which is important!

    You did not say you installed any drivers for your board, etc, by yourself, is that correct? Did you use the driver installation disk that came with your board?

    When I install Windows, I do not connect the Internet to the PC at first. I do that because I want to install the basic drivers for the mother board first, before any of the Windows updates. It is more important to install the board's drivers before any of the Windows updates!

    Yes I know it seems easier to let Windows install everything, but Microsoft is not perfect, they can choose the wrong drivers and you can see the result.

    You need to tell me if you can do the driver installation yourself, which is not hard. You can do it from the board's disk, or from downloading the files from your board's download page.

    If you want to do it yourself, at least part of it, do the following.

    First, this is your board's driver download page for Windows 8.1:

    ASRock > Fatal1ty Z97X Killer

    There are really only two things you need to install before anything else, after that the order does not matter.

    The first thing to install is, from your board's download page: INF driver ver:10.0.13

    That's a .zip file that you right click on in Windows, choose Extract all, and just click Ok after that. Go into the folder that is created, and find the file SetupChipset. Right click on that, and select Run as Administrator. It should finish pretty quickly just fine.

    Second thing to install is, Intel Management Engine driver ver:10.0.0.1204

    Same process as the first driver, extract the driver from the .zip file, go into the folder and find the SetupME file, right click and run as Administrator.

    After that the driver order does not matter.

    About your video card driver, go to MSI's website and get the video driver from them, or use the driver disk that came with your card. If that still fails, we can try to figure it out from there.

  6. #6
    Join Date
    Aug 2014
    Location
    Germany
    Posts
    8

    Default Re: asrock fatal1ty z97x killer - black screen when not using onboard graphics card

    wow, thanks again for your detailed answer!

    your Suggestion sounds reasonable and i will follow your instructions immediately. ill give a Feedback as soon as im finished.

    regards

  7. #7
    Join Date
    Aug 2014
    Location
    Germany
    Posts
    8

    Default Re: asrock fatal1ty z97x killer - black screen when not using onboard graphics card

    hey,

    sadly it didn't work. i dod it exactly the way you discribed but not matter what i tried, when i install the graphics Card Driver i get a black Screen. maybe it's a Problem with Windows 8.1 64bit. any other ideas?

    next Thing i will test is to install win 7 64bit with uefi. hopefully it will work! :/

  8. #8
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: asrock fatal1ty z97x killer - black screen when not using onboard graphics card

    I'm not sure if you're doing this or not, but if you have CSM set to Disabled, that may be what is causing your problem.

    CSM must be set to Enabled unless BOTH of the following are true:

    1. You installed Windows for UEFI booting. That does NOT mean you have a UEFI type BIOS, and installed Windows. If you don't know what UEFI booting is, then you haven't installed Windows in that way.

    2. The VBIOS of your video card supports GOP. Only the manufacture of your video card can tell you is the card's VBIOS is GOP compatible.

    The onboard graphics has a VBIOS that supports GOP.

    Set CSM to Enabled and all of the options under it to Disabled.

    Are you sure the video driver version is for Windows 8.1?

  9. #9
    Join Date
    Aug 2014
    Location
    Germany
    Posts
    8

    Default Re: asrock fatal1ty z97x killer - black screen when not using onboard graphics card

    hey,
    thanks again! so far i set CSM to disabled because i thought that all my components do Support uefi. but now after a Little Research i'm not that sure any more. it Looks like my msi sapphire 270x 2g does not Support UEFI GOPS. if thats the case, i hope to be able to install a new vbios. does any one of you guys knows where i can find such a VBIOS for my Card?

    anyway. so what you are saying is, i shoud enable CSM? within the csm i can set the different Settings like Video OpRAM either to LEGACY or to UEFI. and if i understand you correclty, i should set everything to legacy, right? but everytime i set Video OpRAM to legacy, my Screen stays black after rebooting my System.
    -and i think when it Comes to win8.1, the installer automatically understands that i want to install uefi compatible Windows and i dont have to adjust any Settings.
    -Card Driver should be compatible to win8, i used it before. just on a different Mainboard (with no uefi) with the same graphics Card.

    so in the case my graphics Card has no uefi /gop vbios what can i do?
    setting csm to enable and everything else within the csm Option on legacy does not work because: black Screen when using Video OpRAM 'Legacy'

    should i rather try to install a different vbios?

  10. #10
    Join Date
    Aug 2014
    Location
    Germany
    Posts
    8

    Default Re: asrock fatal1ty z97x killer - black screen when not using onboard graphics card

    (ok according to the msi Support i have the newest vbios and it supports uefi. so it Looks like my graphics Card doesnt cause my Problems, so Windows 8 and/or my Mainboard probablby does.

    any other ideas than trying to install win7 uefi? and why do i Keep getting a blackscreen when Setting Video OpRAM to "legacy" (even not letting me enter bios)?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •