Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: z97 OC MB +3 Sapphire R9 270x - Not working




  1. #1
    Join Date
    Aug 2014
    Location
    USA
    Posts
    2

    Default z97 OC MB +3 Sapphire R9 270x - Not working

    Hello,

    I wonder if anyone could help me out here please.

    I just purchased the ASRock Z97 OC mb. It posted just fine with one Sapphire AMD R9 270X Dual-x graphics card. It was located in the first PCI slot (next to memory/cpu). I then added a 2nd (all the same Sapphires) one in. It also works fine. I went to add the 3rd one into the 3rd slot and I get a great error message as it tries to boot up. The error # is 64 on the lcd readout on the MB. Note: I also tried the 4th slot and got the same error.

    The picture (yes a picture) is an old style MB letting me know I need to connect the 4 pin PSU to the MB. Says, that's why it's not working. It's a great error message and it's animated :) Unfortunately it doesn't help me out:( I thought perhaps it was a bad cable from my power supply or bad Sapphire graphics card. I switched all three around including the power cables. All 3 graphics cards and cables worked in slots 1 & 2. And yes, the other two 4pin power cables that need to go to the MB are in fact plugged in too.

    I loaded the 1.10 bios into the BIOS. That worked fine, no difference unfortunately. Just a side note, I tried Xfire on 1 & 2 with 3rd one in place and 1 & 3 with the 2nd one in place, didn't help. Having the 3rd one always gave me an error. Any ideas?

    Thanks in advance:

    Gunzo

    Update: The R9 270x only has one XFire connector (280x has 2). Make a diff?

    Setup: ASRock z97 OC Formula MB, 32GB Ram, 512GB Samsung SSD, 3x Sapphire R9 270x Dual-x
    Last edited by Gunzo; 08-30-2014 at 12:48 PM. Reason: new info

  2. #2
    Join Date
    Aug 2014
    Location
    Washington
    Posts
    4

    Default re: z97 OC MB +3 Sapphire R9 270x - Not working

    I suppose the obvious question here is what PSU are you running?

    Which 4 pin power cables are you talking about? The molex plug, or your 2 8-pin 12v High Density plugs in the top left? There's a molex connection on the bottom of your board that supplies extra power to the PCIe ports. Also, you need to plug in to PCIe 1, 2, and 4 for trifire. 3 is a shorty. I imagine when you say 3 you mean 4. Crossfire bridges need to be connected to card 1 and 2, and then 2 and the card in 4 need to be connected as well. If your 270x doesn't have a way to bridge the 2 and 4 card, then I imagine they can't trifire. I know Toxic's 270x can trifire, but I'm uncertain if any other variants can.

    On that note, why trifire 270x's? Crossfire has come a long way, and it doesn't have nearly as much stutter as it used to, but tri and quad fire are still pretty awful. Three cards are going to use 300-450w at load! Not only that, they're all going to produce a ton of heat. Since you went all out and have an ungodly amount of ram and Samsung's SSD why short yourself on your graphics card(s)? For the same cost as your 3 270x's you can get 2 280x's or a 290x. While I can't speak on their performance differences, unless you're 4k gaming the 290x can play anything on the market today at its highest settings at well over 60fps.

  3. #3
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default re: z97 OC MB +3 Sapphire R9 270x - Not working

    Welcome to the forum.

    Check out AMD Radeon Technologies, click on the Specs tab and you will see in the AMD CrossFire Support section that 270 series video cards can only run with 2 cards connected by a bridge. You will need 280 or 290 series video cards for a triple Crossfire setup.

    **edit**
    I have changed the thread title
    from: z97 OC MB +3 Sapphire R290x - Not working
    to: z97 OC MB +3 Sapphire R9 270x - Not working
    Last edited by profJim; 08-30-2014 at 06:26 PM.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  4. #4
    Join Date
    Aug 2014
    Location
    USA
    Posts
    2

    Default Re: z97 OC MB +3 Sapphire R9 270x - Not working

    Thanks for the quick replies and the fixing of the title. My bad, my xfire comments sent you both astray in your answers. Sorry. BUT!!

    It was the Molex power connector! I had looked on top of the board itself and didn't see it. But going over the MB more closely, there it was at the far edge of the MB facing to the side. Thank you EmptiMind for the quick response. I have a functioning computer now.

    I regularly use > 20GB of RAM on the 6 monitor set up I have. Thanks again!

    Gunzo

  5. #5
    Join Date
    Sep 2014
    Location
    Toronto
    Posts
    11

    Default Re: z97 OC MB +3 Sapphire R9 270x - Not working

    OP, for this OC Formula z97 mobo if u install ANY 3 cards (even soundcard or pcie ssd, not just 3 graphics card!!) u need to connect an ancient 4 pin molex connector to the mobo. Makes no sense & a very poor design decision by asrock. Furthermore the molex connector is in the bottom left facing DOWN, so in most modern cases thats where the psu is (at bottom of case) & the thick 4 pin molex connector just isnt gonna fit. What were they thinking?? (Or not thinking)

    Im basically forced to abandon my Auzentech soundcard as it wont allow me to use even that in PCIE x1 without the molex connector.(I have 2 GTX 670s in Sli).
    Last edited by poohbear; 09-01-2014 at 10:44 AM.
    Desktop: 4790k @ stock | Noctua NH-D14 | 16GB (2x8gb) Crucial Ballistex @ CL9 | Asrock OC Formula Z97 | Gigabyte GTX 670 SLI | 240gb OCZ Vertex 3 MI & 2TB WD Black | Auzentech Forte 7.1 | Seasonic 760wt Platinum | DELL U2711 @ 1440p | Corsair 300R | Win7
    Ultrabook: Zenbook UX32LN | i5 4200u | 8GB RAM | Nvidia 840m | IPS Matte @ 1080p | 256GB SSD | Win8.1

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •