Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: Z87 extreme4/tb4 blank BIOS on Display port




  1. #1
    Join Date
    Sep 2014
    Location
    United States
    Posts
    9

    Default Z87 extreme4/tb4 blank BIOS on Display port

    I can not access BIOS on my Z87 extreme4/tb4.
    I am running my monitor (UP2414Q) off the motherboards minidisplay port.
    The monitor isn't detected until Windows boots, so it is blank through BIOS.

    Is it possible to access the BIOS with the monitor on the onboard displayport?

    thanks

  2. #2
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: Z87 extreme4/tb4 blank BIOS on Display port

    I haven't had the opportunity yet to experience Thunderbolt, but ...........

    BIOS > Advanced > Intel Thunderbolt / Security Level : Try setting this to DP++

    From the manual:
    Security Level
    Select Legacy to skip the Windows certiication checking process for hunderbolt
    devices. Select Unique ID for checking the Windows certiication, and show
    warning messages if the devices aren't certiied. Or select DP++ to support DP 1.2.
    I'm thinking. loosely, that that might get you a BIOS display screen
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  3. #3
    Join Date
    Sep 2014
    Location
    United States
    Posts
    9

    Default Re: Z87 extreme4/tb4 blank BIOS on Display port

    Thanks, actually it is set for DP++ already.
    I even tried dropping monitor to DP1.1 (30hz) but still no display until Windows start.
    I'm not sure if it is a 4k issue or a DP issue but I may have to connect HDMI to see BIOS.
    Can anyone else see BIOS through the TB/displayport outputs?

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z87 extreme4/tb4 blank BIOS on Display port

    Could your problem be related to the Windows certification of Thunderbolt devices? The BIOS option description is unclear IMO:

    Select Legacy to skip the Windows certification checking process for Thunderbolt
    devices. Select Unique ID for checking the Windows certification, and show
    warning messages if the devices aren't certified. Or select DP++ to support DP 1.2.


    So only Select Unique ID enables Windows certification? My point is if Windows certification is required, and certification can't occur until Windows boots, what happens pre-boot? Un-certified devices are ignored? A long shot really.

    Also, the Thunderbolt Option ROM, which appears during POST if it is not disabled, what does it do? Any configuration options, etc? Use the HDMI connection temporarily so you can check this.

    Your board's download page has a Thunderbolt Controller software ver:1.4.0.1 utility available. Have you used it?
    Last edited by parsec; 09-09-2014 at 02:40 PM.

  5. #5
    Join Date
    Sep 2014
    Location
    United States
    Posts
    9

    Default Re: Z87 extreme4/tb4 blank BIOS on Display port

    Thanks for help.
    Yes I tried Thunderbolt Controller software ver:1.4.0.1, and then more recent v2.04.54
    It appears that Windows sees it as a Display Port, the Intel Thunderbolt utility doesn't show any devices but the Intel Display Manager shows the monitor under Displayport Topology.
    I attached a reduced screencap to illustrate:

    Z87 extreme4/tb4 blank BIOS on Display port-thunderbolt-dp-jpg

    Incidentally, Intel HD 4600 GPU handles 4k 60hz beautifully.
    Display appears in Windows as a single 4k, not MST.
    I don't play 3d but I did try a benchmark it was adequate.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •