Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 1 of 1

Thread: Fatal1ty Z97X Killer issues?




  1. #1
    Join Date
    Sep 2014
    Location
    Estonia
    Posts
    1

    Default Z97X Killer POST hangs when SH-S223C installed

    Occasionally, after booting up the PC or restarting, Z97X Killer hangs on POST. This problem has ~60% chance to occur with BIOS v1.30 and ~90% with every other BIOS version. The hang always lasts for specific time, somewhere between 4-5 minutes and after that continues loading OS normally. I found the cause to be Z97X Killer not liking my TSSTcorp CDDVDW SH-S223C ODD. I noticed sometimes ODD not even being detected/listed in BIOS. After I disconnect ODD from the motherboard, this problem won't occur anymore. The ODD itself works fine with all other motherboards made by MSI and Gigabyte and has never had any failures. There are also no problems with the motherboard or the ODD after successful start up of OS.

    Why doesn't Fatal1ty Z97X Killer like my TSSTcorp CDDVDW SH-S223C ODD?

    System configuration:
    Fatal1ty Z97X Killer
    Intel Core i7-4790 (not K)
    Kingston KVR1333D3N9/4G
    AMD Radeon R9 270X 4GB
    Western Digital WD10EALX-009BA0
    TSSTcorp CDDVDW SH-S223C
    Corsair TX650 PSU
    Windows 7 64-bit
    Last edited by cialawrence; 10-08-2014 at 04:16 AM. Reason: Found out more

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •