Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Q1900-ITX BIOS Update Failed - Stuck in Reboot/Reset Loop




  1. #1
    Join Date
    Jan 2003
    Posts
    5

    Default Q1900-ITX BIOS Update Failed - Stuck in Reboot/Reset Loop

    Recently bought a Q1900-ITX motherboard. Tested OK when installed with new psu and a couple of Samsung RAM sticks. Used Internet Flash feature to update BIOS from v1.20 to v1.30. Update message said restart to complete and i clicked on the OK button. It restarted but no display on monitor, and after 30 to 40 seconds it restarted again. Another 40 seconds later, it restarted again .... and it continues to repeat that! Don't want to power off because install guide says not to do that, but the darn thing is stuck in a loop. How do i overcome this, please?

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Q1900-ITX BIOS Update Failed - Stuck in Reboot/Reset Loop

    Try pressing the Reset button on your PC's case, and once it begins to boot again, press Reset again.

    This might sound like nothing, and these BIOS update boot loops I've seen lately with ASRock boards are scary, but I found a Reset cleared them up, at least for me.

  3. #3
    Join Date
    Jan 2003
    Posts
    5

    Default Re: Q1900-ITX BIOS Update Failed - Stuck in Reboot/Reset Loop

    Quote Originally Posted by parsec View Post
    Try pressing the Reset button on your PC's case, and once it begins to boot again, press Reset again.

    This might sound like nothing, and these BIOS update boot loops I've seen lately with ASRock boards are scary, but I found a Reset cleared them up, at least for me.
    Thanks for your suggestion. Unfortunately, it didn't work. After pressing the Reset button then pressing it again as soon as the computer began to restart did produce another restart but the previous behavior continued, i.e. it ran for 30 or 40 seconds with no display and continues to restart in a 40 second loop, no display.

    ASRock BIOS update instructions said when you first restart after the BIOS update don't worry if it seems not to have worked because the computer will use Internet Flash to do the update again, but that's clearly not happening.

    Any other suggestions to overcome this?

  4. #4
    Join Date
    Jan 2003
    Posts
    5

    Default Re: Q1900-ITX BIOS Update Failed - Stuck in Reboot/Reset Loop

    Update - i think it's fixed! ASRock tech support advised that i shutdown the power completely, remove 24-pin power plug, remove the cmos battery, move the cmos jumper to pins 2 - 3 for a few seconds, move jumper back to pins 1-2, restore cmos battery, and restore 24-pin power connector. When i powered on again the display was back and i pressed F2 to enter the BIOS, where it shows i now have the latest BIOS version. Hooray! Thanks again for your assistance here, too!

    UPDATE 10-21-2014 - Since the successful BIOS update the reset/restart problem recurred. Again following ASRock tech support advice, i tested each stick of RAM memory separately and discovered the reset/restart problem stopped when one of the RAM sticks was removed. Ordered some new RAM.
    Last edited by StarvinMarvin; 10-22-2014 at 11:31 PM. Reason: Problem update and resolution

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •