Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: bios 140 z97 extreme6 ?




  1. #1
    Chuckus is offline Junior Member
    Join Date
    Jul 2014
    Location
    California
    Posts
    14

    Default bios 140 z97 extreme6 ?

    Has anyone used or have information on this?
    I did not find on the Asrock support site, I was checking for drivers with tuning utility and it was listed. I was hoping it might resolve some of the sleep hibernation issues.I was also hoping for updated audio drivers.


    I looked on Asrock site but couldn't find it.

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: bios 140 z97 extreme6 ?

    Quote Originally Posted by Chuckus View Post
    Has anyone used or have information on this?
    I did not find on the Asrock support site, I was checking for drivers with tuning utility and it was listed. I was hoping it might resolve some of the sleep hibernation issues.I was also hoping for updated audio drivers.


    I looked on Asrock site but couldn't find it.
    So you looked for it, found it, but could not find it?

    UEFI 1.40 is listed and can be downloaded now: ASRock > Z97 Extreme6

    I've had Sleep issues with UEFI 1.20, as in the PC wakes from Sleep a few seconds after going into Sleep. That could be a UEFI issue, but also could be caused by many other things, so is a pain to diagnose.

    I'm off to try 1.40, which will take a while since I must recover all my UEFI settings, as the UEFI updates normally remove all the profiles I save. I understand why that is done, but still annoying.

    Or were you looking for updated audio drivers?

  3. #3
    Chuckus is offline Junior Member
    Join Date
    Jul 2014
    Location
    California
    Posts
    14

    Default Re: bios 140 z97 extreme6 ?

    I found it via tuning utility. When I went to support site under downloads I didn't see it listed.
    I checked tuning utility in hopes of finding an updated asrock approved mb audio driver. I have some sort of feedback buzzing when I play D3 but not with any other games.
    I mentioned the z97 sleep apnea because it seems like quite a few people have that issue.

    I'm on 130 now which is what was on the board when I purchased.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •