Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Fatal1ty H97 Killer can't force turbo boost?




  1. #1
    ukiy is offline Junior Member
    Join Date
    Mar 2011
    Location
    Split
    Posts
    4

    Question Fatal1ty H97 Killer can't force turbo boost?

    Hi,
    So i have i5-4570 with turbo boost of 3.6GHz on H97 Killer mbo with latest UEFI (v1.40), and it seems that turbo boost can't be forced. If i enable "CPU OC Fixed mode" and set CPU ratio to 36, in Windows CPU-Z keep showing 3.4GHz and only sometimes bumps to 3.6GHz.
    On my previous mbo, MSI B85-G43 Gaming, everything was fine, i was able to constantly keep 3.6GHz.
    Is this limitation of H97 chipset or am i doing something wrong?

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Fatal1ty H97 Killer can't force turbo boost?

    I don't think it's the H97 chipset that is causing the drop in CPU ratio, both the H97 and B85 do not support over clocking.

    Given the description of CPU OC Fixed Mode, it should act the same on this board, as it did on the B85 board.

    Does your BIOS have any options like Long Duration Power Limit and Long Duration Maintained, which determine how much power and how long the Turbo ratio will be maintained?

    Other possibilities are CPU temperature issues, but that would be extreme and unlikely. Or possibly a bug in the BIOS. Do you have any of the CPU power saving options enabled? Such as EIST, C1E, and other C States?

  3. #3
    ukiy is offline Junior Member
    Join Date
    Mar 2011
    Location
    Split
    Posts
    4

    Default Re: Fatal1ty H97 Killer can't force turbo boost?

    Quote Originally Posted by parsec View Post
    ...
    Hi,
    Thanks for reply...

    UEFI does have "Long Duration Power Limit" and "Long Duration Maintained" along with "Short Duration Power Limit" and "Short Duration Maintained".
    Also, there is option called "Primary Plane Current Limit".
    Honestly, i don't know how to use them, they are all set to "Auto" right now. Any tips?

    All CPU power saving options are disabled.
    Last edited by ukiy; 09-25-2014 at 08:45 PM.

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Fatal1ty H97 Killer can't force turbo boost?

    We can try the Power Limit settings first, who knows what the default values are in both boards, they could be different.

    In the BIOS, go to the Short Duration Power Limit, and press the + key on the keyboard, a number should be displayed. Increase that number to at least 84 (watts). Same thing for the Long Duration Power Limit.

    Actually, having certain power saving options disabled can cause Turbo to behave differently. Try enabling EIST (speed step), it does not harm an OC.

    I suggest using something else besides CPU-Z for monitoring CPU speed, try HWiNFO64, here: HWiNFO, HWiNFO32/64 - Download

    Personally, I use moderate over clocks, and have all CPU power savings enabled, works fine.

    Turbo boost is meant to be temporary by design, over clocking boards and processors (neither of which you have) can override that. To do this with non-over clocking hardware may take more work.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •