Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Any suggestions please, hard drive controller on N68c-s UCC appears faulty, unable to find drivers




  1. #1
    Join Date
    Oct 2014
    Location
    United Kingdom
    Posts
    1

    Default Any suggestions please, hard drive controller on N68c-s UCC appears faulty, unable to find drivers

    Hi,

    I have a AS Rock N68c-s UCC with AMD Athlon II x 4 processor. I am running Windows 7 sp1.

    The system is (I think) about 4 years old and up until a few weeks ago was running without too many issues.

    I have now started experiencing problems which usually present as a single beep (not a bios beep, this can happen at any point during use) followed by the hard drive resetting and lag. Sometimes it causes a complete crash. With the help of a techy friend we have narrowed the problem down to (we think) the storage controller, listed in the device manager as Nvidia nforce serial ATA controller. These state that the drivers for the software are up to date, and there appears to be no way to replace them.

    The event log lists NVstor64 errors which appear to coincide with the beeps and crashes. Although I've found many mentions of these errors causing problems going back several years, I am struggling to find a working solution.

    I have tried re-installing windows but the problem has persisted and I am at a loss where to go next (short of buying a new motherboard which I really can't afford atm).

    If anyone has any useful suggestions they would be much appreciated.

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Any suggestions please, hard drive controller on N68c-s UCC appears faulty, unable to find drivers

    It sounds like you've done a good job diagnosing your problem. The only exception to that is the hard drive(s), particularly the Windows C: drive, not mentioned in your post. Is the OS drive as old as the rest of the PC? Do you have confidence in it? Have you ever tried using another drive for the Windows drive?

    I can't say that the drive is the problem, just another possibility.

    Another potential problem could the the power supply in that PC. Or simply unplugging and reconnecting the power cables to the board, creating a fresh connection might help.

    The cables and connections, both data and power, to the drives should also be refreshed like this if not done for a long time.

    The Nvidia chipsets (NVIDIA GeForce 7025 / nForce 630a, the 630a containing the SATA controller) were not very good, known to have problems, and currently have a status of obsolete. Nvidia stopped manufacturing them several years ago, and all support for them (new drivers) also ended at that time.

    Your board's download page has the NVIDIA SATA2 driver ver:11.1.0.30 available, at least on the ASRock website for the USA. That file contains both the IDE and RAID drivers (dated 2009) for your chipset/board.

    You could try downloading whatever SATA driver version Nvidia has on their website for your 7025/630a chipset, it could be newer than the version ASRock has for your board.

    It seems you said you cannot update the driver for the SATA controller in Device Manager? Meaning no generic Windows driver is listed as an alternative?

    But given what you have already done to fix the problem, including installing Windows and the drivers again, if refreshing all the cable connections as I mentioned above does not help, the board itself may be the problem, sorry to say.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •