Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 1 of 1

Thread: ASRock Fatal1ty Z97X Killer 2 USB ports don't work




  1. #1
    Join Date
    Oct 2014
    Location
    Arizona
    Posts
    1

    Default [Solved] ASRock Fatal1ty Z97X Killer 2 USB ports don't work

    Hi all,

    I just built my new system. Here is the specs (Intel Core i7-4790K, Gigabyte GeForce GTX 970, Fractal Design Define R4 w/Window (Black Pearl) - i7 970 - bensonhui's Saved Part List - PCPartPicker). So far I love it but I am having a bit of challenge.
    At the back it has 6 USB 3.0 ports, the middle 2 3.0 ports don't work but it has power. The bottom 2 work but they are running in 2.0 speed. I already tried to install the new driver but doesn't solve. Am I missing anything? (The USB ports at the front panels are working fine.)

    Note: My device Manager is showing 2 unknown. They are still there even I installed all drivers.
    ASRock Fatal1ty Z97X Killer 2 USB ports don't work-capture-png

    Got the problem solved by installing ASMedia_USB3.0_Drivers_1.16.12.0
    Last edited by bensonhui; 10-23-2014 at 09:09 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •