Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: ASRock B85 Anniversary - Problem installing intel IME drivers after fresh setup - help




  1. #1
    Carlosa is offline Junior Member
    Join Date
    Nov 2014
    Location
    germany
    Posts
    2

    Default ASRock B85 Anniversary - Problem installing intel IME drivers after fresh setup - help

    Hi,

    I have a complete new system

    - ASRock B85 Anniversary
    - Intel Core i5-4460S
    - Windows 7 professional 64bit

    I have just setup everything and installed Windows.
    Now I am about to install all the drivers in the correct order.

    1. Intel Chipset Drivers - done
    2. Intel rapid storage technology - done
    3. Intel Management Engine Components - Error
    4. VGA Drivers
    5. Audio
    6. LAN Drivers
    7. the rest of your drivers and utilities for your laptop/computer

    The error says:
    The setup could not install one or more device drivers. Setup is cancelled.

    I have downloaded the latest drivers from here:
    ASRock > B85 Anniversary
    I also tried the IME driver from the CD, which is the same version, but ended up with the same error.

    So, now what? Any idea about that error?
    Should I ignore it and carry on with the rest of the drivers?


    Should I try a different version from here: https://downloadcenter.intel.com/Sea...agement+engine
    But which one?

  2. #2
    Join Date
    Feb 2008
    Posts
    97

    Default Re: ASRock B85 Anniversary - Problem installing intel IME drivers after fresh setup - help

    You don't need those drivers.

    2. Intel rapid storage technology - done
    3. Intel Management Engine Components - Error

    It's just useless software.

  3. #3
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASRock B85 Anniversary - Problem installing intel IME drivers after fresh setup - help

    The Intel Management Engine Components are not worthless, particularly for a B85 board.

    Not sure why ASRock has not updated your board's download page with this information, but there is a Windows update that fixes the installation error that happens with the IME software. An example of that can be seen on this board's page:

    ASRock > H97 Anniversary

    Link to the Windows update: Download Kernel-Mode Driver Framework version 1.11 update for Windows 7, and Windows Server 2008 R2 from Official Microsoft Download Center

  4. #4
    Carlosa is offline Junior Member
    Join Date
    Nov 2014
    Location
    germany
    Posts
    2

    Default Re: ASRock B85 Anniversary - Problem installing intel IME drivers after fresh setup - help

    Quote Originally Posted by parsec View Post
    The Intel Management Engine Components are not worthless, particularly for a B85 board.

    Not sure why ASRock has not updated your board's download page with this information, but there is a Windows update that fixes the installation error that happens with the IME software. An example of that can be seen on this board's page:

    ASRock > H97 Anniversary

    Link to the Windows update: Download Kernel-Mode Driver Framework version 1.11 update for Windows 7, and Windows Server 2008 R2 from Official Microsoft Download Center
    Thanks for the information. But that is funny, I actually tried that update but could not install it. I did some research in the web before I registered here and asked for help. And I stumbled across that possible fix. But as I said, I couldn't install it.

    Anyway, I continued with installations of all drivers and when I wanted to update Win7, the update function did'nt work. I couldn't do any updates. So I had to do some research work again and finally found out that the Rapid Storage RST driver causes an error on Win7 64bit Pro when it is installed without prior SP1 and makes updates impossible.

    Great, isn't it?

    I intentionally did a clean installation without integrated SP1 because I have read that one shouldn't use integrated SPs because they can mess up the driver installation process.

    So, I am now doing a clean reinstallation in the following order:
    (I have read that process on the forum where I read about the RST causing windows update error)

    - win7 installation
    - Intel Chipset Drivers
    - win online updates (incl sp1)
    - java installation
    - intel online updates (needs java)
    - win online updates
    - repeat until no more further updates
    - .net framework 4.5 installation
    - win online updates
    - repeat until no more further updates
    - installing the rest of the drivers

    2. Intel rapid storage technology
    3. Intel Management Engine Components
    4. VGA Drivers
    5. Audio
    6. LAN Drivers
    7. the rest of your drivers and utilities for your laptop/computer


    Honestly, I have set up many systems. But this....

  5. #5
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASRock B85 Anniversary - Problem installing intel IME drivers after fresh setup - help

    The only thing I would change in your installation order is install the Intel Management Engine Components before the IRST software.

    The order I always do is the Intel Chipset file installer and then the Intel Management Engine Components. After that the order really does not matter.

    I've used Windows 7 iso installation files with SP1 included, installed the Chipset and IME software right after the installation is complete, and never had the problems you have.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •