Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Asrock ION 330 Won't Display HDMI




  1. #1
    Join Date
    Nov 2014
    Location
    United States
    Posts
    2

    Default Asrock ION 330 Won't Display HDMI

    I have 2 AsRock ION 330 systems that I have been using for years without issue. About a week ago, one of them started making fan noises. I didn't have time to do anything at the time so I shut it down and unplugged it. Went to clean it out today and plug it back in, now I don't get any video displaying over the HDMI. It is connected to my AV receiver, but I also tried connecting directly to my TV. I took my other ION 330 system down and tried the same TV with the same results. Can this be a power supply issue? I'm not really sure where to go here since I can't see anything. Please help!

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Asrock ION 330 Won't Display HDMI

    So it sounds like both of your AsRock ION 330 systems seem to be no longer sending video to your TV, is that right?

    Do you only have one power supply that you use with both of the ION 330 systems?

    Does that happen with the HDMI cable connected directly to the TV, with both AsRock ION 330 systems?

    If so, one possibility is the HDMI cable might be bad, can you test it with another source like another PC or a DVD player? Be sure you are selecting the correct input on the TV, sorry but had to throw that in too.

    If the failure to get any video to the TV happens with both systems using the same power supply, then a bad power supply is a possibility.

    If the HDMI cable tests fine, that also points to the power supply, if both systems don't seem to function with it. I would be wary about trying that PSU again, since it might damage the PCs.

    You may be stuck getting another power supply in order to test if the other one is bad, unless you can borrow one or have a store test the PC with a power supply they have.

  3. #3
    Join Date
    Nov 2014
    Location
    United States
    Posts
    2

    Default Re: Asrock ION 330 Won't Display HDMI

    Ok the power supply is what I figured. Unfortunately the power supply for the second system is behind a lot of equipment and tough to get to so I was not able to test it. I have ordered a new PSU and will update after it arrives.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •