Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Z97 extreme6: Am I ok with Ram that is not on the compatibility list?




  1. #11
    Join Date
    Nov 2014
    Location
    Houston
    Posts
    5

    Smile Re: Z97 extreme6: Am I ok with Ram that is not on the compatibility list?

    Quote Originally Posted by parsec View Post
    I thought that was the problem. Even though you have one bad DIMM out of four, the good news is your board is not the problem, the fourth slot is not bad.

    More good news is G.SKILL has a lifetime warranty on their products. They also have a forum right here at TweakTown:

    G.Skill

    A G.SKILL rep monitors that forum, just explain what happened and maybe add a link to this thread and ask what you should do. Or go to G.SKILL's website and start an RMA.

    You may need to return the whole kit to them for a new one, but overall you'll get a new fully working kit.


    Didn't know that about G.Skill. thanks for the info, I shall contact them I appreciate your help, this was a very easy fix.

  2. #12
    Join Date
    Nov 2014
    Location
    Houston
    Posts
    5

    Default Re: Z97 extreme6: Am I ok with Ram that is not on the compatibility list?

    Quote Originally Posted by jimbo0u812 View Post
    Didn't know that about G.Skill. thanks for the info, I shall contact them I appreciate your help, this was a very easy fix.
    I know its been a bit but thought I would update my RMA experience with G.Skill. Not much to say but "Excellent" I shipped my memory on a friday, G.Skill recieved it on that next Wed. and by Sat of that same week I had 4 working modules. Thats It! Thanks Guys

    Jim

  3. #13
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: Z97 extreme6: Am I ok with Ram that is not on the compatibility list?

    Glad to hear that the new memory fixed the problem and that G.Skill provided excellent service wth your RMA.

    Thanks for the update.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •