Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Asrock 990FX Extreme 4 dead sata ports?




  1. #1
    Join Date
    Jan 2011
    Location
    Cohocton, New York, United States
    Posts
    4

    Question Asrock 990FX Extreme 4 dead sata ports?

    My pc was working fine yesterday and all of a sudden today decided to reboot by itself in the middle of basic web browsing and now wont load windows (says to insert boot media). I've tried every hard drive I own and every configuration I can possibly think of to fix the problem and nothing is working. I've tested every hard drive and anything else I can think of outside of the pc case and on other hardware. Hard drives are fine and everything works perfectly on my spare hardware. I even went as far as trying a few different bios versions going back as far as the stock bios (2.00) that came on my motherboard. I've also tried every single sata port on the entire motherboard including the ones run by the marvel controller. None of them will allow me to boot into windows. It just instantly reboots over and over or tells me to insert bootable media to continue. I've formatted my SSD and my HDD along with all my spare hard drives and nothing is working at all. I can post into UEFI fine and make all the changes I like but the board refuses to post into windows. Check disk on all hard drives reveals no errors so all my hard drives are working as they should. I was using windows 8.1 if that means anything. Even my power supply passes all voltage tests. What could cause this?

    System Specs:
    Asrock 990Fx Extreme4 MB
    AMD Fx 4300 Quad Core CPU
    GSkill Ripjaw 1333 Ram (2GBx4) 8GB
    EVGA GTX660SC
    OCZ Vertex 128GB SSD
    Seagate Barricuda 1TB HDD
    750w Power supply
    Generic DVD Drive
    Windows 8.1

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Asrock 990FX Extreme 4 dead sata ports?

    Very strange, given that both SATA interfaces (AMD and Marvell) are apparently non-functional.

    The spontaneous nature of your problem, from your description, makes me think one of the following might have occurred:

    The power supply system on the board itself that supplies power to the AMD SB950 and Marvell SE9120 chips broke.

    One or more rails of your PSU expired (12V or 5V) and are not supplying the board with power.

    The same faulty rail(s) of your PSU is not supplying power via the SATA power cables to the drives.

    I know you said your PSU passed your voltage tests, but how did you test it? Under a no load condition with a volt meter? That type of test may seem fine, but when a load is put on the PSU, a rail's voltage might drop considerably.

    What "750 w power supply" are you using? A true multi-rail PSU could supply power to the board but have a failure on a separate rail used to supply power to the drives.

    A bad cable connection to the drives that was barely working could have failed. A pin or two on a connector could be out of place and cause no power to get to the drives.

    I assume none of the drives were visible in the BIOS SATA/Storage configuration screen?

    I would definitely try a different power supply with that board/PC, such as the one you used to test the drives in the other PC. If the result is the same with the other PSU on the 990FX board, that would tend to indicate that the board itself is the problem IMO.

    Or try a different power cable to the drives, and check the cable(s) connectors for any pins out of place. If your PSU is modular, that is more likely to happen.

  3. #3
    Join Date
    Jan 2011
    Location
    Cohocton, New York, United States
    Posts
    4

    Default Re: Asrock 990FX Extreme 4 dead sata ports?

    I may have fixed the problem. I went back to the original bios that came on the board when I first bought it (2.00) and now its reading and writing from the hard drives. The drives and everything did show in my bios but would refuse to do anything past trying to post to windows and immediately restarting. I was using bios version 2.50 when the error started and I upgraded to 2.70 (most recent on Asrock site) and that didn't fix the problem. I went all the way back to 1.00 to start with when I re-flashed the bios after scratching my head for a while. That fixed the problem but gave me "1394 guid are invalid in both cmos and flash" which I knew it would. Now my problem is that even after flashing back to the 2.00 bios that came on my board I am still getting said error. So as it sits right now I am using bios 2.00 and am installing windows 7 as I type this.

    I had to swap out my CPU from the FX4300 to my Phenom II 960T after I flashed to the 1.00 bios to get the board to even post so I could test the sata ports. I doubt the 4300 was the problem but I'm not actually sure if it was. I haven't switched back to the FX4300 yet but everything seems to be working now even tho I get the CMOS flash error. Ill keep messing with it and see if I can replicate what happened the first time it started acting up. With any luck the bios swapping around fixed the issue for now. Either way I haven't been real impressed with this board at all so it will be getting replaced when the funds allow it. Overcloking or lack of is what is killing me on this board.


    Edit: Fixed the guid error using a thread from on here. Back up and running for now.
    Last edited by sukkafree63; 12-13-2014 at 10:50 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •