Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 8 of 8

Thread: Sata - conflicts? Sata3-ssd not used for boot when sata2-hdd is connected




  1. #1
    Join Date
    Dec 2014
    Location
    Nederland
    Posts
    4

    Default Sata - conflicts? Sata3-ssd not used for boot when sata2-hdd is connected

    This weekend I installed my new Asrock 980DE3/U3S3 motherboard. I connected both my Samsung 840 SSD and 2 Samsung HDD's.

    SSD = Sata 3

    HDD's both on Sata2 ports

    When booting, only the sata 2 ported disks are used; in BIOS also the SSD can't be selected (while - of course - my SSD is my bootdisk). I played around with the AHCI-settings, but didn't manage to get things working.
    What am I doing wrong?
    When de HDD's are disconnected the SSD is used for booting, so it is connected correctly I guess.

    Besides that, while booting I get a message about a not supported IDE-drive. I don't have any IDE-drive connected and even disabled this in the BIOS. How can I avoid this?

    Thanks for your help!
    Last edited by mikekiwi; 12-18-2014 at 11:14 PM.

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Sata - conflicts? Sata3-ssd not used for boot when sata2-hdd is connected

    As you probably know, the SATA III ports on your board are provided by the ASMedia 1061 SATA chipset. Do you have the ASMedia SATA driver installed?

    The Onboard SATA3 Operation Mode option in Storage Configuration in the BIOS must be set to AHCI for the ASMedia ports.

    In the BIOS Boot Screen, what do you see in the Hard Disk Drives option? Anything that needs to be configured? Can you see the SSD in the list of drives, and possibly move it up in the list of drives so it will appear as the 1st Boot Device?

    I'm going by your board's manual for the BIOS options, and I know BIOS updates can change or add options, so I might be missing some of them.

    What version of Windows are you using?

    That IDE drive message must be related to a drive on either the SATAII_5 or SATAII_6 ports. So you have SATA IDE Combined Mode disabled in the BIOS?

  3. #3
    Join Date
    Dec 2014
    Location
    Nederland
    Posts
    4

    Default Re: Sata - conflicts? Sata3-ssd not used for boot when sata2-hdd is connected

    Quote Originally Posted by parsec View Post
    As you probably know, the SATA III ports on your board are provided by the ASMedia 1061 SATA chipset. Do you have the ASMedia SATA driver installed?

    The Onboard SATA3 Operation Mode option in Storage Configuration in the BIOS must be set to AHCI for the ASMedia ports.

    In the BIOS Boot Screen, what do you see in the Hard Disk Drives option? Anything that needs to be configured? Can you see the SSD in the list of drives, and possibly move it up in the list of drives so it will appear as the 1st Boot Device?

    I'm going by your board's manual for the BIOS options, and I know BIOS updates can change or add options, so I might be missing some of them.

    What version of Windows are you using?

    That IDE drive message must be related to a drive on either the SATAII_5 or SATAII_6 ports. So you have SATA IDE Combined Mode disabled in the BIOS?
    Thanks for your reply! Below the screenshot before your post



    Then I changed some settings, set operation mode to IDE tried several boots and then the SSD suddenly appeared in the boot options. Then I changed the order of the disks to make the SSD the first drive:



    After that I changed the settings to your recommendations



    As you can see, the cdrom is now onm SATAII_3. But still:




    I get this message even when I disconnect the sata cables from all drives, except for the SSD (forgot to try that one, I'm now thinking).

    ASmedia driver is installed (although it is partly in another language, I think you can see what I mean):



    So, current situation is that booting is o.k. now, thanks for that! Now the only challenge is the ATAPI-message (not IDE as I initially wrote).

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Sata - conflicts? Sata3-ssd not used for boot when sata2-hdd is connected

    Great, AMD boards tend to have confusing SATA options, glad that worked for you!

    I think you forgot one setting, SATA IDE Combined Mode, is that still enabled? If it is, set it to disabled.

  5. #5
    Join Date
    Dec 2014
    Location
    Nederland
    Posts
    4

    Default Re: Sata - conflicts? Sata3-ssd not used for boot when sata2-hdd is connected

    Data IDE combined mode is now disabled , the atapi message still Pops up however...

  6. #6
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Sata - conflicts? Sata3-ssd not used for boot when sata2-hdd is connected

    That is so strange... or are we so not used to using PATA IDE drives (with the 40 pin ribbon cables) that we don't know of all their quirks. Such as, you don't have any PATA drives connected, yet you get that message, is that normal, I ask rhetorically?

    An ATAPI drive means a CD/DVD drive, if that is a clue to the situation.

  7. #7
    Join Date
    Dec 2014
    Location
    Nederland
    Posts
    4

    Default Re: Sata - conflicts? Sata3-ssd not used for boot when sata2-hdd is connected

    Quote Originally Posted by parsec View Post
    That is so strange... or are we so not used to using PATA IDE drives (with the 40 pin ribbon cables) that we don't know of all their quirks. Such as, you don't have any PATA drives connected, yet you get that message, is that normal, I ask rhetorically?

    An ATAPI drive means a CD/DVD drive, if that is a clue to the situation.
    The stupid thing is that I had a dvd-drive connected via IDE at first when I booted this machine. Then the atapi-message came. So I replaced the IDE-drive with a sata-version to avoid the message. But it didn't disappear... It seems that somehow the bios still has the connected IDE-cable in its memory (a bios-cookie? ) or something like that...

    To me the biggest issue was of course the SSD/HDD boot-issues, this atapi-message is easy to overcome by hitting F1 while booting. But hey, since we are already busy solving problems, let's get rid of all messages...

  8. #8
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Sata - conflicts? Sata3-ssd not used for boot when sata2-hdd is connected

    You need to do a CMOS/BIOS clear with the BIOS clear jumper on the board. Have you ever done that before? The PC must be shutdown, the PSU turned off and unplugged from AC power. Check your board's manual for details.

    After any BIOS clear, it will have all options reset to default values. You'll need to set the options back to the settings you were using before the BIOS clear.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •