System specs:
AMD A10 7700K cpu / Asrock FM2A88M Extreme4+ mobo / Windows 7 64 bit / Crucial M500 120 GB SSD
I had a pair of 4Gb GSkill ARES DDR3 RAM 1600 mhz from previous build.....
so I bought another pair to fill all four RAM slots in this new board. Exactly the same make/type/spec.etc.

I had a few initial problems setting up the system. I got some help from this forum but further problems led me to having the PC checked out at a friend's PC shop. All my devices checked out OK and final thoughts were a problem existed on the mobo.
At home again, I tried a clean install of Windows, BIOS set up with defaults, and just two sticks of RAM in place. PC ran fine for several hours that day so I continued to use it in that setup for a week. Then I tried to add my second pair of RAM modules.
PC booted up OK but crashed after 5 mins. or so, and continued in that way until I removed the second lot of RAM.
I tried every combination of two RAM modules from the four I had. Any two of the modules worked OK, in either the A!/B1 or the A2/B2 slot positions. The Asrock mobo manual mentioned that with RAM rated at 1600 or above then use the A2/B2 slots - they do give better performance in that position rather than A1/B1 - I've measured it.
But the manual doesn't say what you are supposed to do if you want to fill all the slots!
This begs a few questions......what is the difference between the two pairs of RAM slots and will they all support 1600 MHz or faster RAM at all?
I have not had a straight answer to that question as yet.
While the PC was running steadily I noticed another problem - that the onboard USB3 was not working and no matter which driver I installed, from the mobo CD, or from AMD or ASrock updated ones I downloaded - they still remained dead.
Email exchanges with Asrock support failed to rectify the problem although we did find that USB3 is live in BIOS setup, but not Windows and we concluded it was probably a faulty mobo.
So I exchanged it for a new one thro' the supplier....... but it gives exactly the same problems.

Further email exchanges with another Asrock engineer suggested either RAM incompatabilty or a faulty cpu for the crashing problem (as the cpu houses the memory controller he said) .............and a Windows driver problem for the USB3 being dead (as it works in BIOS but not in Windows), which does make sense.
At this point I probably would have accepted using just two RAM modules if the USB3 had been OK.

I'm not convinced that the cpu is faulty........ otherwise why does it run OK with two RAM slots used?
And if the RAM module pairs are incompatibile how come I can swap any two from the four and the PC remains stable? So I'm thinking of giving up on this Asrock mobo totally and getting a refund.
Before I do can anyone suggest a way forward.
Thanks, Bobajob