Greetings friends!

I'm having trouble getting my new gpu to work in my rig. Here's what I have:

asrock z68 extreme3 gen3 (BIOS 2.3)
8gb ram
i5-2400 cpu
cx600m psu

Up until now, I've been using the GTX 660ti without a hitch (and had a 450w psu at the time). I decided to upgrade my gpu and picked up a Gigabyte radeon r9 290 windforce (the one with the three fans). I bought the cx600m because I figured I'd need the extra power as well. I installed the gpu, got the 6 and 8 pin power cords hooked up, but for some reason, the new card doesn't show up in device manager and won't output when I use the HMDI or VGA ports. I tried downloading the AMD drivers, and got the catalyst software off their site. The installer loads, but doesn't seem to actually install any drivers, I'm thinking because the mobo doesn't recognize the card. There doesn't seem to be a way to bypass Catalyst either and install the drivers manually.

Long story short, I tried updated my BIOS for the first time thinking this might solve the issue...HORRIBLE idea. I didn't see the numerous posts about how updating the BIOS on the z68 kills sandy bridge processors. Couldn't boot to windows, just got an endless loop of the loading screen and then crashed and reset. Took me all night to figure out a solution, but reinstalling windows at least allowed me to get back in.

I feel like I've tried everything I found on forums - tried the gpu in the other PCI express slot, reset cmos, made sure the boot up is set to the PCI express slot, disabled the intel mobo graphics, tried other catalyst - nothing seems to work. I tried the card out in my buddy's rig and it gets recognized fine. Any ideas why this isn't working in mine??

Thanks so much for any help!