Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 1 of 1

Thread: [Audio] [Z97M-ITX/ac] Neither 5.1 Analog (back) nor Digital (optical), but 2-channel Analog (front) and HDMI (TV) work




  1. #1
    bjsmith413 is offline Junior Member
    Join Date
    Dec 2014
    Location
    US-FL-Sanford/Oviedo
    Posts
    1

    Default [SOLVED} [Audio] [Z97M-ITX/ac] Neither 5.1 Analog (back) nor Digital (optical) work, but 2-channel Analog (front) and HDMI (TV) do

    [SOLVED] No issue with the mainboard. I did some deep dives in a Linux boot and looking at "raw" values in the ALC892 via kernel/ALSA, along with some extensive plug testing, and I verified of the outputs, their soft-toggles, etc... are all working nominally. So, in the end, it ended up not being a Windows/driver issue either.

    The problem is actually with my 5.1 surround audio system. The control unit is working (e.g., the headphone jack on the 5.1 audio system itself works, verifying line-in), but the relays seem to have died, or at least blown a fuse (so I don't get any output from speakers). It was just working the other week. Just a coincidence it happened between the last time I used it (before upgrading to the Z97M) and the first time I used it (after upgrading).

    --

    This one has left me speechless with a new ASRock board. I have enabled/disabled HDMI audio on so many systems prior, including using 5.1 direct (3 cables) analog with other mainboards with a Realtek ALC8xx series, including in this very case attached to this very TV, with a prior board.

    Problem:

    I cannot get the audio ports on the back I/O panel of the board to give me any output, even thought Windows is sending audio (as it thinks the devices are enabled/usable) as verified in the stock Windows volume mixer.
    - 5.1-channel direct (3x 1/8" for front-L/R, rear-L/R and center/sub, respectively)
    - Optical direct (Toshlink)

    I disabled HDMI at the TV and in the "Playback devices" so the TV does not show in the audio mixer. This usually works just fine with other ALC8xx series, reverting back to the on-board analog, including with this very TV. I've done this so many times, so I'm really dumbfounded with this new Z97M-ITX/ac board.

    Even in the "Realtek HD Audio Manager", it even shows the connectors are plugged in for front-L/R, rear-L/R and center/sub (1/8") ports, as well as the Digital (optical). I've played with the "Set Default Device" on the "Speakers" as well as tried the "Digital Output" to no output on either as well.

    The funny thing is, what does work are the following ...
    - 2-channel direct (1x 1/8") when I plug into the front panel of the case, connected via the "HD Audio" header
    - HDMI out (nVidia GTX 660 Ti), when enabled, whether set to default device or not

    The fact that the header works for 2-channel analog is dumbfounding. The only thing I can think of is that it's somehow permanently enabled, preventing the rear audio from working. I also played with the "Device advanced settings" and tried to verify, and even change away from, "Mute the rear output device, when a front headphone plugged in." The only thing I haven't tried yet, but will when I get more time, is to yank the "HD Audio" header to the front panel. You never know with some cases, but this case just had another board in it with another ALC8xx series and had no problem switching between headphones on the front header and rear.

    Anyone else have any suggestions?


    Components/Configuration:

    I have the ASRock Z97M-ITX/ac with the ALC892 audio updated to the latest P1.12 firmware, running Windows x64 version 7 Ultimate edition, all patches installed.
    SIDE NOTE: It's booting native 64-bit uEFI/GPT disk label, if that matters, no BIOS/MBR used at all.

    I have the latest ASRock Realtek High Definition 6.0.1.7004 from the ASRock site.

    As a last resort, I was also going to try the generic Realtek HD Audio Codecs direct from Realtek, taking my own "restore point," so I can roll back.

    I also need to test this with the Advanced Linux Sound Architecture (ALSA), since I also have Fedora x86_64 r20 installed on this system. That would at least let me test it with the Linux kernel + nVidia drivers and see if I can get audio out of the 5.1 audio.
    Last edited by bjsmith413; 12-24-2014 at 03:01 AM. Reason: SOLVED

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •