Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Problem with Asrock 960gm/u3s3 fx and fx-6300 cpu.

  1. #1
    Join Date
    Jan 2015
    United States

    Question Problem with Asrock 960gm/u3s3 fx and fx-6300 cpu.

    I'm having problems getting the motherboard to post. I have 8gbs G. Skill Ripjawz 2x4, corsair cx 500 psu, and sapphire r7 260x. I don't have a speaker so I can't hear beeps, but I have tried removing one of the ram sticks and switching slots. Tried that with both and can't get a signal to monitor. I have the necessary power cables plugged in as well. The board receives power. I'm thinking it needs updated to support the cpu. The box came with a disc that says AA76B-12C version 1.2c. Any help would be appreciated. Thanks.

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Third stone from the sun

    Default Re: Problem with Asrock 960gm/u3s3 fx and fx-6300 cpu.

    A FX-6300 CPU needs BIOS 1.20 or newer to work. There should be a sticker on the BIOS chip, near the battery, that shows the version from the factory.

    Saying you are using G.Skill "Ripjaws" memory is almost like saying you're using DDR3 memory, there are many different model numbers that are all called Ripjaws. You'll need to be more specific about the model number, for example, Model F3-12800CL10S-8GBXL is one model of Ripjaws memory. A quick scan of the memory support list shows only one model of Ripjaws memory listed.

    ASRock > 960GM/U3S3 FX

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts