Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Asrock Vision 3d 137B does not startup anymore




  1. #1
    Join Date
    Jul 2014
    Location
    Netherlands
    Posts
    2

    Default Asrock Vision 3d 137B does not startup anymore

    Dear,

    My Asrock Vision 3d 137B does not startup anymore, I probably already found the issue, but thats also still a bit challenging. ;-)
    The poweradapter does not show a light anymore when plugged in to the powersocket.

    The Poweradapter supplied with the device is:
    Delta Electronics INC
    ADP-90CD DB
    100-240V ~ 1.5A
    19V 4,74A
    N17908

    I already ordered a new universal poweradapter (ADP-90CD DB) but the plug on the new is different so it does not fit.
    I already emailed ASrock, but i takes them some time to get back to me it seems.

    Any advise how to tackle this? maybe someone already has some experience with this or knows which adapter should be ordered
    Could also try a universal with plugs that can be replaced... but would like some advice first! ;-)

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Asrock Vision 3d 137B does not startup anymore

    Besides the power supply's light being on, the only way to test it is with a volt meter, but that does not put any load on it.

    Does the new power supply's plug that goes into the PC not fit? Or is the AC power cord not compatible with your AC outlet?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •