Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: 970 Extreme 3 R2.0 UEFI freeze




  1. #1
    Join Date
    Jan 2015
    Location
    Poland
    Posts
    2

    Default 970 Extreme 3 R2.0 UEFI freeze

    Yesterday i changed my GPU from R7 260X to GTX 760. I was bit worried about this change cause my PSU is Thermaltake Litepower 500W (only 360W on +12V), but in windows everything runs fine (didn't played any demanding game yet, but run furmark few minutes + whole 3dmark demo). Only problem I have is that when i enter UEFI it just freezes after about 2 seconds, with 260X it works fine. I don't know if its something wrong with this GTX760, its some compatibility problem beetween mobo and GPU or just PSU is not enough (but then why it runs good in windows under stress?). I will try to borrow some stronger PSU from my friend or put my GPU to his PC and check this, but this will be in few days so maybe you can help me earlier.

  2. #2
    Join Date
    Jan 2015
    Location
    Poland
    Posts
    2

    Default Re: 970 Extreme 3 R2.0 UEFI freeze

    So i finally changed my PSU (wanted to do this anyway) and the problem still exists, everything works fine in windows (Bioshock: Infinite runs in 2560x1440) but I can't acces my BIOS. Should I RMA GPU? How to check what is causing problem?
    EDIT: Just realised that my GPU was working at PCIE x4 (it was in x16 slot), after putting my GPU in second slot i can access BIOS so probably its just x16 slot fault, gonna RMA mobo.
    Last edited by redpatyk; 01-28-2015 at 05:47 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •