Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: AsRock 970 Extreme4 not recognizing all 8 cores.




  1. #1
    Join Date
    Jan 2015
    Location
    Maryland
    Posts
    3

    Default AsRock 970 Extreme4 not recognizing all 8 cores.

    I have an AsRock 970 Extreme4 and an AMD FX 8320 Eight Core processor. The motherboard doesn't seem to recognize all 8 cores and only picks up 3. The website states that it supports the cpu if updated to the 2.60 bios which I have done and still nothing. I've tested my cpu in my brothers desktop which has a Gigabyte 990-FXA-UD3 and it recognizes all 8 cores. What is the issue here? I've contacted AsRock support and they claim that its my cpu (without any proof or details to back up why they say such a thing) which to me is inconceivable since it works in another motherboard with no issues. Is anyone able to help me out here?

    AsRock 970 Extreme4 not recognizing all 8 cores.-cpu-mobo-jpg

  2. #2
    sofargone88 is offline Junior Member
    Join Date
    Jan 2015
    Location
    West Lafayette
    Posts
    2

    Default Re: AsRock 970 Extreme4 not recognizing all 8 cores.

    Had this happen on an AMD 8core. Almost RMA'd it till I found this.

    windows 8.1 - Task Manager shows one processor (and not multiple cores) - Super User

  3. #3
    Join Date
    Jan 2015
    Location
    Maryland
    Posts
    3

    Default Re: AsRock 970 Extreme4 not recognizing all 8 cores.

    Quote Originally Posted by sofargone88 View Post
    Had this happen on an AMD 8core. Almost RMA'd it till I found this.

    windows 8.1 - Task Manager shows one processor (and not multiple cores) - Super User


    Thank you SOOOO VERY MUCH. It picks them all up now. But since it only showed 3 cores before, does that mean it wasn't running at its full potential before? or was it always running with all 8 cores and windows just didn't show it visually?

  4. #4
    sofargone88 is offline Junior Member
    Join Date
    Jan 2015
    Location
    West Lafayette
    Posts
    2

    Default Re: AsRock 970 Extreme4 not recognizing all 8 cores.

    Mine wasn't running all cores. I was having problems with low benchmark scores and I opened CPUZ and saw that some cores weren't reporting. Not sure how they got turned off or why it's even an option to turn them off. I seriously doubt you could just shutdown bad cores and still have a CPU work properly.

  5. #5
    Join Date
    Jan 2015
    Location
    Maryland
    Posts
    3

    Default Re: AsRock 970 Extreme4 not recognizing all 8 cores.

    Quote Originally Posted by sofargone88 View Post
    Mine wasn't running all cores. I was having problems with low benchmark scores and I opened CPUZ and saw that some cores weren't reporting. Not sure how they got turned off or why it's even an option to turn them off. I seriously doubt you could just shutdown bad cores and still have a CPU work properly.
    Yeah I figured out it wasn't running full scale yet. I just simply redid the windows assessment and my score jumped from a 6.4 to a 7.6

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •