Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: AsRock UEFI/BIOS terror continues.... :o(




  1. #1
    Join Date
    Nov 2013
    Location
    slovakia
    Posts
    21

    Thumbs down AsRock UEFI/BIOS terror continues.... :o(

    I'm using Asrock mainboards for many years and PCIe implementation is JUST NIGHTMARE:

    -old S775 (wolfdale 1333 Glan atx) was unable to post with AMD PCIe 2.0 graphics cards... luckily unlisted BIOS from Asrock support helped!

    -new old S775 (wolfdale d667 mAtx) was again unable to post with Nvidia PCIe 2.0 graphic card... with new BIOS no change - i was forced to just get rid of GK and use onboard one


    And FINALY my CURRENT NIGHTMARE -> AsROCK P67 PRO (with newest BIOS flashed)
    First trouble was when trying to get it work with 750Ti card (650Ti works fine). It just stopped to boot at post-up screen for minutes and when trying to access setup the screen turns to unreadable garbage...

    Changing setting "ROM PRIORITY" from `EFI compatible ROM` to `LEGACY ROM` helped to solve the issue (of course i have first to plug old GK to be able to enter UEFI setup menu)

    But now i'm screwed. I decided to get USB 3.0. I tried 3 controllers for PCIe 1x (older renesas D720200a, same renesas with latest firmware and new ETRON EJ168 controller).
    In all 3 1x PCIe slots the computer FREEZES with EVERY CARD with code `99` in lower right corner...
    All controllers are working just fine in other computers!!!


    What's wrong with AsRock??? The board is not new type, i can't believe it is still not `mature`

    Btw. no response from AsRock tech-support ... :(

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: AsRock UEFI/BIOS terror continues.... :o(

    Well, you make it sound like a current or new ASRock board can't work with your video cards. But all your mother boards are rather old...

    The Wolfdale1333-GLAN has a PCIe 1.0 interface, with the newest drivers from the Vista era. This board is seven years old.

    The AsROCK P67 PRO board's last BIOS is from 2012. You mention using the latest BIOS, which is 2.20. But did you flash to 2.10 before that? If you didn't or did not flash 2.10 correctly, that may be part of your problem. You MUST flash to 2.10 before you can use 2.20. If you skipped 2.10 and flashed to 2.20, you just messed up your BIOS.

    Did you also update the Intel IME software, which is required for BIOS 2.10 and beyond?

    Also, why were you using the EFI compatible ROM? Unless you flashed the VBIOS of your 650TI for UEFI ROM compatibility, there is no reason to do that. Also, depending upon who made your 750TI, it might not have a UEFI compatible VBIOS. Simply having UEFI firmware in a board does not mean all your hardware can use UEFI option ROMs. That is why the OROMs are set to Legacy by default.

    Are you using a UEFI booting Windows installation? What OS are you using?

    I'll give you that the BIOS of those two boards have not been updated in a long time. A mature platform is only mature if it has BIOS updates that match current hardware. The last BIOS update for your P67 board is dated 2012.

  3. #3
    Join Date
    Nov 2013
    Location
    slovakia
    Posts
    21

    Thumbs down Re: AsRock UEFI/BIOS terror continues.... :o(

    Parsec, thanks for your answer but i'm affraid that you don't understand my post at all:

    I listed my bad experiences with Asrock mainboards and MOSTLY TERRIBLE SUPPORT!!!!
    Experiences in the past and not all MB were for my personal use ->

    -wolfdale 1333 GLAN was bought about 8 years ago (that time relatively MODERN MB with DDR3 support, near the best you can get from S775).
    I wanted to use it with actual AMD graphic card, that was unfortunately already PCIe v2 (that should be backward compatible).
    Good thing is that AsRock made the fix, bad thing is that it was `secret` (not published on their website at all)!!!!!!

    -wolfdale d667 was bought about that same time (8 years) for relatives -> unfortunately i bought again PCIe v2 version of discrete Nvidia GK (V1 versions of that GK were refreshed that time with V2)
    Latest BIOS from Asrock mentioned to fix this was not solving the issue...

    -my own P67pro mainboard was bought a year ago brand new, great MB with many PCI slots. I wanted to use new GK (750Ti) 3 MONTHS AFTER DATE OF PURCHASE, do i want so much??? The MB was shipped with already built-in `refreshed` IB support etc....
    So in `ASROCK WORLD` the MB after 3 months is `obsolete` with no support??? 8-O TERRIBLE!!!!


    some more constructive words ->
    -MB was sold already with latest BIOS (i'm 100% sure min. 2.10 with IB support),
    -i have already latest BIOS with latest drivers from Asrock website in the time of purchase
    -trouble arrives IMMEDIATELY after powering up of computer, even in the case no HDD is connected - so question about OS i'm using is irelevant by my opinion...
    -650Ti worked fine in both modes, 750Ti not (that is the reason why i first flashed newest BIOS for GK, I tried to contact the manufacturer of GK (Giga-byte) first, but with no response)

    Solution of turning off UEFI ROMs was FINE FOR ME, till the time i WASN'T able to POST the computer (freeze in one second after power up) with 3 different USB 3.0 controllers plugged in :o(
    btw. i deliberately bought first one with relatively OLD CHIPSET and firmware (dated 2011) to `match` the MB....

    Am I wanting so much??? At least do you understand why i'm shaking in horror just imagining of trying to use PCIe card in Asrock MB?
    Is Asrock so `crappy` company, that it can't at least try to fix the problem at MB they sold year ago? And giving no answer is the communication a'la AsRock?

    I bought AsRock mainboards because of `clever HW solution` (many PCI slots, great layout - for example two slots gap between PCI and PCIe x16 for using GK with huge cooler and good airflow...), but i'm JUST TIRED of their shoddy and buggy BIOS firmwares :o(



    btw. WHAT MEANS that number `99` in the lower right of boot screen, where it always freezes with any plugged in PCIe USB controller???
    Last edited by spcxxx; 01-16-2015 at 04:42 AM.

  4. #4
    Join Date
    Nov 2013
    Location
    slovakia
    Posts
    21

    Default Re: AsRock UEFI/BIOS terror continues.... :o(

    So i checked the original label on the BIOS chip, and the mainboard was shipped with latest version V2.20 already installed...
    (I'm not surprised, because it was bought 12/2013 brand new)
    It was used just with IB CPU (that's why i was sure there was min 2.10 already installed by manufacturer)

    Now i can tell sure the BIOS was not updated by myself and it can't be obvious case of bad BIOS update mentioned here on the site and the issue PARSEC was probably thinking about.

    This is probably all just about bad implementation of F..KING UEFI HELL, that make the life even of specialist so more complicated :o(
    Last edited by spcxxx; 01-16-2015 at 09:03 PM.

  5. #5
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: AsRock UEFI/BIOS terror continues.... :o(

    My point about the board being older has nothing to do with when it was purchased. It could be new out of the box today, but if its BIOS version is from 06/2012, it is a 2.5 year old BIOS trying to work with video cards that were designed years after the BIOS was released.

    But that does not excuse the lack of BIOS update support for new, basic hardware, like a video card. Particularly on a board that only supports video cards, no on board graphics.

    ASRock ignores BIOS support in cases like this at their own risk.

  6. #6
    Join Date
    Nov 2013
    Location
    slovakia
    Posts
    21

    Default Re: AsRock UEFI/BIOS terror continues.... :o(

    Yeah, I understand how do you mean it...

    But i think the sale date is MOST IMPORTANT, because when AsRock wants to sell mainboards longer (maybe they got good price for `obsolete` chipset, or they have too much boards left on the stock they want to get rid off them.... i don't know and i don't care),
    then this makes an OBLIGATION to give longer support for product, too....

    There is NO TECHNICAL REASON to avoid longer support - i don't expect from them to support DDR4 or new CPUs that aren't supposed to by supported by specification!!!

    I just want to use PCIe slots on their MB with product that SHOULD WORK according all specs...


    Here we are at `AsRock forum`, so i like to stick the theme and not *****ing about GigaByte awful support and ignoration -> is anyone from Asrock actualy reading this forum?
    Or somebody experienced that can give me some more information how to get the PCIe stuff to work??? And it's not some `exotic hardware`, just ordinary GK from leader manufacturer and the most common USB 3.0 controller in the world for christ sakes!
    Last edited by spcxxx; 01-17-2015 at 07:40 AM.

  7. #7
    Join Date
    Jan 2015
    Location
    Earth
    Posts
    13

    Default Re: AsRock UEFI/BIOS terror continues.... :o(

    ASROCK is on my never-again list.

  8. #8
    Join Date
    Nov 2013
    Location
    slovakia
    Posts
    21

    Default Re: AsRock UEFI/BIOS terror continues.... :o(

    It is terrible that they even don't care at least answer the question for TechSupport :o(

  9. #9
    Join Date
    Nov 2013
    Location
    slovakia
    Posts
    21

    Default Re: AsRock UEFI/BIOS terror continues.... :o(

    I looked on ASROCK website, and there is bunch of newer BIOS downloads for other same `obsolete` P67 boards like:
    ASRock > P67 Pro3
    ASRock > P67 Pro3 SE
    ASRock > Fatal1ty P67 Professional

    I found even 2014 BIOS for P67 PRO3 board (i have P67 PRO) here in this forum:
    ASRock Beta BIOS


    Descriptions of updates are like:
    -Improve PCIE compatibility.
    -Improve VGA compatibility.
    -Improve discrete VGA card vBIOS compatibility.

    Simply THAT'S IT, WHAT I'M DREAMING ABOUT DEAR ASROCK!!!!!!


    Please, someone at ASRock WAKE UP and at least respond to you customer who contacted you thru tech-support long time ago...

  10. #10
    Join Date
    Nov 2013
    Location
    slovakia
    Posts
    21

    Default Re: AsRock UEFI/BIOS terror continues.... :o(

    What's difference between `pro` and `pro 3` version?
    ASRock > P67 Pro3
    http://www.asrock.com/mb/Intel/P67%20Pro/

    It looks exactly the same (just bigger heatsinks and LED display), but i'm affraid to flash this BIOS, that should SOLVE ALL MY ISSUES:
    (dated 11/25/2014!!!!!)
    ASRock > P67 Pro3
    Last edited by spcxxx; 02-01-2015 at 07:43 PM.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •