A couple of days ago I upgraded from a EVGA P55 motherboard to a ASRock Extreme6 motherboard. I am very happy with the new motherboard except for one issue. With my EVGA setup I had my main computer speakers plugged into the front speaker/headphone jack on the motherboard and when I plugged head phones into the front headphone jack on my case, the rear front speaker/headphone jack would cut off. Also in Windows 8.1 it would notify me that a new audio device had been plugged into the audio jack.

With this new setup this does not work. When I plug my headphones into the front audio jack I get no sound through them, but the speakers on the rear jack works fine. Also Windows 8.1 does not notify me that anything has changed.

Things I have checked:
1. Headphones still work, tested with external audio source.
2. Front jack cable is connected to the motherboard correctly.
3. Windows 8.1 is up to date with all patches applied.
4. RealTek Drivers are up to date.
5. UEFI is up to date.

6. Desktop Speakers and realtek sound work, tested with music and games.
7. Checked UEFI and the front audio jack is set to "Automatic" there is no "Enable" just "Automatic and Disable".
8. Even tried installing older RealTek drivers.

After searching around the internet I was reminded that the RealTek HD audio control panel has a folder icon you can use to toggle advanced options such as automatic jack cutoff and front jack usage. And I remember having to do this with my old EVGA setup. However when I opened the control panel I was presented with this.


No folder! So clicked on the "Device Advanced Settings" and got this dialog.


I enabled the bottom option hit ok and I got a new tab.


However this does NOTHING unless you set it as the Default Device. But now only the front jack works, but not the rear jack.

I would really like to get back to the auto switching/cutoff my old EVGA board gave me. Having to switch inputs manually through the GUI is not very convenient Any other things to try? Time to buy a dedicated sound card?

Thanks!