Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: ASRock Q1900DC-ITX will not boot




  1. #1
    Join Date
    Feb 2015
    Location
    the Netherlands
    Posts
    1

    Default ASRock Q1900DC-ITX will not boot

    Hardware:

    ASRock Q1900DC-ITX motherboard (BIOS P1.20)
    Toshiba 65 Watt power adapter
    Toshiba 2.5'' HDD
    tried with:
    Samsung PC3-8500S 1GB memory
    Kingston KVR1333D3S9 4GB memory

    After building the system, there is no signal on both HDMI and VGA display outputs. Also, the lights on the USB connected keyboard don't turn on.
    When I use the DDR3-A1 slot, the speaker beeps three times. When I use the DDR3-B1 slot, the speaker does not beep.
    In both cases, the HDD spins up.

    I never had issues with installing a motherboard and I didn't expect to have them with this 'simple' Bay Trail motherboard!

    What am I doing wrong here? Or is is just a faulty motherboard?

  2. #2
    Join Date
    Mar 2015
    Location
    Nederland
    Posts
    1

    Default Re: ASRock Q1900DC-ITX will not boot

    I have the same problem as rstijn. I finished updating the bios to 1.20 correctly. After the bios update I rebooted the system and checked if there were new bios options. I shutdown the system and connected an hdd and usb drive for installation of an OS. But the motherboard didn't boot.
    I will attache a speaker to the motherboard to check if it also beeps 3 times

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •