Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: ASRock Z87 Pro4 Post Beep Confusion




  1. #11
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASRock Z87 Pro4 Post Beep Confusion

    Quote Originally Posted by camhig81 View Post
    That's right parsec. It's a weird situation. I press the power button, the fan on the GPU spins up, the CPU fan spins up, the case fans spin up. Then three beeps, pause, three beeps. Then CPU fan throttles down a few hundred rpm's (guestimate)then the process starts again. No signal to screen during the whole process.

    I feel confident that I've exhausted the RAM dimms as being the issue as they boot in another pc without any issues. I've also tried a different brand of tested, working RAM with still no luck. I think the final test will be the PSU and, failing that, I'll look at a new m/b. I need to get this back up and running so I might end up picking up a new one then continue to troubleshoot this one.
    Ok, as I thought that sounds like a "POST loop" for lack of a better term.

    I'm familiar with the behavior of the system fans on ASRock boards when the PC starts, mine do exactly what you described, but only once since my PCs boot fine. The fan behavior is only their normal reaction before the fan speed control kicks in.

    The POST process is failing early in its sequence of events, and is apparently starting over. That might be the Boot Failure Guard feature of ASRock boards causing POST to start over again, which is normal. But that does seem to tell us that the problem is very basic.

    IMO, if it is not the PSU then the board has a problem, and you probably should not waste time trying other fixes. So I tend to agree with you about the board.

  2. #12
    Join Date
    Feb 2016
    Location
    Ukraine
    Posts
    1

    Default Re: ASRock Z87 Pro4 Post Beep Confusion

    Hello all,

    I have faced with the same issue, with the definitely the same symptoms.
    And i have good news for all of you - there is only one simple solution: You need downgrade BIOS version to 2.0.
    ASRock > Z87 Pro4

    Downgrade helped me to avoid this issue,and now my PC works fine=).

    I hope my finding will help you.

    Regards!

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •