Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: Z97 Extreme6/AC Wireless Lan driver for Windows 8.1 x64 (setup.exe) -- freezes OS when clicked




  1. #1
    javaguy993 is offline Junior Member
    Join Date
    Feb 2015
    Location
    Maryland
    Posts
    3

    Default Z97 Extreme6/AC Wireless Lan driver for Windows 8.1 x64 (setup.exe) -- freezes OS when clicked

    I'm trying to use the wireless LAN functionality for my new ASRock Z97 Extreme6/AC motherboard. I've updated bios to the latest version (P 1.20). I didn't see any options to join any wireless networks in Windows 8.1, so I went to the ASRock web site to install the driver titled "Wireless Lan driver". (The driver is located here: ASRock > Z87 Extreme6/ac) After I downloaded the driver, unzipped it, and then clicked the setup.exe file, Windows freezes. I restarted Windows and tried again, but the exact same thing happens, and I'm forced to reboot Windows. The driver appears to be from BroadCom and is digitally signed by BroadCom: WLAN_Broadcom(v6.30.223.170)

    Interestingly, Windows also freezes when I try to install the regular LAN driver. Any suggestions of things to try would be greatly appreciated. My system specs are below.

    CPU: Intel i7-7490K
    Motherboard: ASRock Z97 Extreme6/AC
    Memory: Ballistix 16GB 2-8GB Elite
    Harddrive: Samsung SSD 850 EVO 500GB
    Graphics card: none (on motherboard)
    OS: Windows 8.1 Professional 64-bit

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z97 Extreme6/AC Wireless Lan driver for Windows 8.1 x64 (setup.exe) -- freezes OS when clicked

    Quote Originally Posted by javaguy993 View Post
    I'm trying to use the wireless LAN functionality for my new ASRock Z97 Extreme6/AC motherboard. I've updated bios to the latest version (P 1.20). I didn't see any options to join any wireless networks in Windows 8.1, so I went to the ASRock web site to install the driver titled "Wireless Lan driver". (The driver is located here: ASRock > Z87 Extreme6/ac) After I downloaded the driver, unzipped it, and then clicked the setup.exe file, Windows freezes. I restarted Windows and tried again, but the exact same thing happens, and I'm forced to reboot Windows. The driver appears to be from BroadCom and is digitally signed by BroadCom: WLAN_Broadcom(v6.30.223.170)

    Interestingly, Windows also freezes when I try to install the regular LAN driver. Any suggestions of things to try would be greatly appreciated. My system specs are below.

    CPU: Intel i7-7490K
    Motherboard: ASRock Z97 Extreme6/AC
    Memory: Ballistix 16GB 2-8GB Elite
    Harddrive: Samsung SSD 850 EVO 500GB
    Graphics card: none (on motherboard)
    OS: Windows 8.1 Professional 64-bit
    Is the link to the download page you provided above a mistake? It's the download page of the ASRock Z87 Extreme6/AC.

    You wrote Z97 Extreme6/AC many times, so I assume that is correct. That board's download page for Windows 8.1 is here:

    ASRock > Z97 Extreme6/ac

  3. #3
    javaguy993 is offline Junior Member
    Join Date
    Feb 2015
    Location
    Maryland
    Posts
    3

    Default Re: Z97 Extreme6/AC Wireless Lan driver for Windows 8.1 x64 (setup.exe) -- freezes OS when clicked

    Good catch, parsec. I meant to provide the z97 download link, located here: ASRock > Z97 Extreme6/ac
    This is what I use when Windows 8.1 crashes.

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z97 Extreme6/AC Wireless Lan driver for Windows 8.1 x64 (setup.exe) -- freezes OS when clicked

    I thought so, no big deal.

    I use a Z97 Extreme6, but not the AC model. They seem to be identical besides the inclusion of the wireless/BT module and antenna.

    I use Windows 8.1 with my Z97 Extreme6 board, and use both of the wired network chips in the board. I've installed Win 8.1 (and Win 10 TP) multiple times, and of course the drivers for the two network chips. I have never had a freeze when installing any driver or software while using this board.

    I don't see anything in your board's manual about the wireless module except how to connect the antenna, and the option to enable or disable it in the UEFI. ASRock includes small manuals in the box about certain features, like the board's Apps and utilities. Any chance there is a separate manual for the wireless module?

    Also, what is your Internet Setting in the UEFI? Mine is set to DHCP for my ISP.

    Otherwise, did you run the INF driver ver:10.0.13 installation program? ASRock apparently forgot to update the installer version for your board, most if not all of the other 9 series chipset boards have the INF driver ver:10.0.21 available. It may not make any difference, but worth a try, I'm sure you can use the version from my board's download page:

    ASRock > Z97 Extreme6

    Just download and run it, no harm done if run multiple times. Not a driver, it installs INF files used by other programs to identify the Intel hardware on a board.

    Did you install the Intel Management Engine driver ver:10.0.0.1204 software? That's really needed to get all the features of your chipset working. Again, not the latest version, check the same download page of my board for the latest.

    Always good to right click on the installer programs and run as Admin.

    Otherwise, no idea what is happening to you. Any OC on the CPU?

  5. #5
    javaguy993 is offline Junior Member
    Join Date
    Feb 2015
    Location
    Maryland
    Posts
    3

    Default Re: Z97 Extreme6/AC Wireless Lan driver for Windows 8.1 x64 (setup.exe) -- freezes OS when clicked

    I'll give the INF a shot. Thanks for the suggestion, parsec.

    Here is some more info I discovered on the problem: If I use the drivers/install program for the (non wireless & realtec) LAN on the CD that ships with the motherboard, nothing crashes. However, if I use the install files from ASRock's web site, it crashes. Unfortunately though, ASRock didn't include a wireless lan driver on the CD, so I'm still in the same boat.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •