I built this computer in 2012 and everything has worked fine until now. The major components are:

  • ASRock X79 Extreme6 LGA 2011 Intel X79 SATA 6Gb/s USB 3.0 ATX Intel Motherboard
  • Intel Core i7-3930K Sandy Bridge-E 6-Core 3.2GHz (3.8GHz Turbo) LGA 2011 130W Desktop Processor BX80619i73930K
  • 32GB of G.SKILL Ripjaws X Series 16GB (4 x 4GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 14900) Desktop Memory Model F3-14900CL9Q-16GBXL
  • EVGA 02G-P3-1559-KR GeForce GTX 550 Ti (Fermi) 2GB 192-Bit GDDR5 PCI Express 2.0 x16 HDCP Ready SLI Support Video Card
  • CORSAIR TX Series CMPSU-750TX 750W ATX12V v2.3 SLI Ready CrossFire Ready 80 PLUS
  • BRONZE Certified Active PFC Compatible with New 4th Gen CPU Certified Haswell Ready

If it matters I am running a dual boot (via GNU GRUB) Ubuntu/Windows 7 box.

The problem I am having is as follows: the other day my computer was on, then went dark but the fans were still running. I wasn't at my computer so I didn't see it happen. I did a hard shutdown. This weekend I tried to use it and noticed the CLR CMOS button was lit and the motherboard would get hung up at Dr. Debug code 67 (CPU DXE initialization - CPU module specific). I would not get any beeps out of the machine.

So far this is the timeline of what I have done:

  1. Removed CMOS battery and manually reset CMOS with jumper. Still doesn't boot. No change.
  2. Removed graphics card. Still doesn't boot. No change.
  3. Removed all RAM and got the "no RAM" beep. I tested each stick in the A1 slot and the computer boots into Windows with each stick individually (which tells me each stick is fine?). I then added one stick at a time with reboots in between to see if it is a RAM slot problem. With all slot filled everything is fine and computer boots. MemTest86 says that all my RAM is fine. At this point my problem was "fixed" but for unknown reasons.
  4. The next morning after the computer sat overnight I had the same problem where I got Dr. Debug code 67. I removed 2 sticks of RAM in the B-bank of the motherboard and my computer works. I then added the same 2 sticks of RAM back in to the B-bank of the motherboard and the computer booted up fine, but just like before, it wouldn't boot up the next day.


This is a really strange problem (at least to me) and I have no idea how to fix it.