Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 6 of 6

Thread: X99 Extreme99 won't post




  1. #1
    Join Date
    Mar 2015
    Location
    US
    Posts
    2

    Unhappy X99 Extreme99 won't post

    Hello,
    I am having a lot of trouble getting my setup working. Here are my components:

    Motherboard: ASRock X99 Extreme4
    CPU: 5930k
    Cooler: Corsair H60
    RAM: 4x8GB Corsair DDR4 2600
    GPU: Gigabyte GTX 770 4GB
    SSD: Crucial MX100 512GB
    PSU: OCZ ZX 1000W

    When I power on, I get 5 beeps, a red light by the BIOS chips, and no video signal. What I've tried so far:

    -Varying the number of RAM sticks (1-4) while maintaining slot order A1,B1,C1,D1. When 3 or 4 DIMM slots are filled, the beeping does not occur, nor does the red light turn on. If this happens, the machine needs can only be turned off via forced shutdown.
    -Varying the PCI-E slot (1 or 3) of the GPU.
    -Trying a different GPU (I have two identical 770 GTXs), both of which result in the 5 beeps.
    -Plugging or unplugging the SSD.
    -Have tried clearing the CMOS settings and tried all the variations above with both the primary and backup BIOS settings.

    In all these configurations, I have the CPU fan 1 and 2 plugged in.

    Please help =(

  2. #2
    Join Date
    Mar 2015
    Location
    US
    Posts
    2

    Default Re: X99 Extreme99 won't post

    Update: plugging in a keyboard resolves the beeping on startup, but there is still no video (have tried HDMI and DisplayPort).

  3. #3
    Join Date
    Nov 2015
    Location
    Australia
    Posts
    1

    Default Re: X99 Extreme99 won't post

    So I'm having seemingly the same issue as you! Go me!

    I also posted about it on reddit; https://www.reddit.com/r/buildapc/co...fter_previous/

    Did you figure out any way to resolve it?

  4. #4
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: X99 Extreme99 won't post

    To you both, please contact ASRock Tech Support HERE, explaining you're getting 5 beeps(no video card detected), tell them your video card, and politely request that they roll you a BIOS with support for your video cards.

    Doing so and then receiving and flashing this new BIOS file from them will solve your issues.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  5. #5
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: X99 Extreme99 won't post

    Oops, me bad.

    Senor Freebie,

    Just read your Reddit. Try this. With the computer unplugged, press the Power button, pull your video card of choice, reset the BIOS by pulling the batter and jumpering if this board has jumpers, re-jumper and replace the battery, and now assuming the second card you have is a lessor of your first choice card, plug it into a slot and connect power cables if necessary, and try booting with the lessor card.

    The OP here was using two of the same cards. Which, obviosly, if it's a BIOS recognition issue, both wouldn't have been recognized.

  6. #6
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: X99 Extreme99 won't post

    The above should I hope get you a working computer. Albeit w/o the card of choice, until ASRock gets you a new BIOS out the door.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •