Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: Having Issues With Brand New PC. Just built.




  1. #1
    Bit_Strife is offline Junior Member
    Join Date
    Mar 2015
    Location
    United States
    Posts
    3

    Default Having Issues With Brand New PC. Just built.

    I just put together my PC. You can see the specs in my sig but I'll link the build anyway. AMD FX-6350, PowerColor Radeon R9 290X, NZXT Phantom (White) - System Build - PCPartPicker (The monitor is wrong because I decided not to order that one yet and use my old one.)
    I put it together last night and this morning. All seemed to be well. I turned it on and the monitor wasn't getting any signal from HDMI. So I went out and bought DVI cords. No luck there either. I've been digging around since with the help of some friends and it would seem that my motherboard and my CPU aren't compatible? Is this the case? What can I do about it? Any help would be much appreciated.

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Having Issues With Brand New PC. Just built.

    The FX-6350 is compatible with your board, it is listed in the CPU support list: ASRock > 970 Extreme3 R2.0

    The list has the official full model number, but as long as you see the "6350" in it, that's your CPU.

    Practically zero to go on, no signal to monitor, but what else is happening? Fans spinning on the CPU cooler and case? Video card fan running?

    Does your monitor have automatic input selection, or do you manually select an input? If not in auto mode, you might need to select the input manually.

    Do you have a four/eight pin CPU power cable connected to the board, as well as the 24 pin power cable? Power cable for video card connected?

    No POST beeps from the board? Do you have a beep speaker connected?

    You might have a memory compatibility problem, what is the full model number of your memory? There are multiple RipJaws models, and I'm not talking about speed.

  3. #3
    Bit_Strife is offline Junior Member
    Join Date
    Mar 2015
    Location
    United States
    Posts
    3

    Default Re: Having Issues With Brand New PC. Just built.

    Quote Originally Posted by parsec View Post
    The FX-6350 is compatible with your board, it is listed in the CPU support list: ASRock > 970 Extreme3 R2.0

    The list has the official full model number, but as long as you see the "6350" in it, that's your CPU.

    Practically zero to go on, no signal to monitor, but what else is happening? Fans spinning on the CPU cooler and case? Video card fan running?

    Does your monitor have automatic input selection, or do you manually select an input? If not in auto mode, you might need to select the input manually.

    Do you have a four/eight pin CPU power cable connected to the board, as well as the 24 pin power cable? Power cable for video card connected?

    No POST beeps from the board? Do you have a beep speaker connected?

    You might have a memory compatibility problem, what is the full model number of your memory? There are multiple RipJaws models, and I'm not talking about speed.
    Edit: CPU and Graphics Card fans are running. Not the case ones.

    I have to manually select it and I did. Still got no single.

    Yes, I have those connected.

    I got no sounds when trying to use earphones. I don't have a beep speaker connected.

    G.SKILL Ripjaws X Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 14900) Desktop Memory Model F3-14900CL9D-8GBXL

    Edit: I just went through and made sure everything was connected and still having the same issue.
    Last edited by Bit_Strife; 03-15-2015 at 02:55 PM.

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Having Issues With Brand New PC. Just built.

    Ok, the G.SKILL XL model is not listed in the memory support list, but G.SKILL claims it is compatible with AM3+ systems. Something to keep in mind, if you have some other memory to try in this board, just one DIMM, could be worth it for a test.

    The case fans (some, all) are connected to the mother board fan headers, or using the fan controller in your NZXT case? I have this case, when using its fan controller you must connect the four pin molex connector for the case to your PSU.

    No beeps will be sent to headphones or speakers, you must have the tiny speaker plugged into the board. You might have one supplied with your case, check the hardware box. That little POST beep speaker can really help identify what is wrong. They cost less than $2 if you must buy one.

    You should start disconnecting things from the board, such as all your drives and even the keyboard and mouse. Then try starting the PC, you can get into the BIOS without any drives connected. Testing the video card in another PC may be necessary to verify it is working.

  5. #5
    Bit_Strife is offline Junior Member
    Join Date
    Mar 2015
    Location
    United States
    Posts
    3

    Default Re: Having Issues With Brand New PC. Just built.

    After having some more knowledgeable friends come over and do some tinkering and getting the beeps to occur we got it working. Thanks for your help!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •