Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: ASROCK Q2900-ITX and the function wake on lan




  1. #1
    Join Date
    Mar 2015
    Location
    Brazil
    Posts
    8

    Default ASROCK Q2900-ITX and the function wake on lan

    Hi guys,

    this is my HTPC configuration, running Windows 7 ultimate 64 Bits + Plex server and HT + Unified Remote + wifi network

    MOBO ASRock Q2900-ITX

    Case - Antec Mini-ITX Case ISK110-VESA

    MEMO - Crucial 8GB Kit (4GBx2) DDR3 1600 MT/s

    HD - Kingston Digital 120GB SSDNow V300 SATA 3 2.5 (7mm height) with Adapter Solid State Drive 2.5

    Wi-Fi / Bluetooth - Intel 3160 Dual Band Wireless AC + Bluetooth Mini PCIe card Supports 2.4 and 5.8Ghz B/G/N/AC Bands

    Dual Wi-fi Antenna Kit 5Dbi RP-SMA Antennas and 20cm/8" U.fl/IPEX to RP-SMA Cables

    Everything is fine except for one detail when I set the MOBO in BIOS to wake on lan / wan.....if I set this option to ENABLE, it is impossible shutdown the computer.

    When I shut down (windows or plex or unified remote) the computer restarts itself....if I disable the option in BIOS, I can shut down the computer properly.

    I wanna to ENABLE this option to wake the computer through Unified Remote or any wake on wan app.

    Any help ?

    Thank you guys.

    Flavio





  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASROCK Q2900-ITX and the function wake on lan

    I assume you are just using the Intel 3160 wireless network card, and have nothing connected to the Realtek RTL8111GR network chip on your board?

    Do you have the Intel driver installed for the 3160 wireless card?

    I don't use a 3160 card, but in its Device Manager Properties, Power Management tab, where the WOL settings are, do you have options under Power Saver such as Respond to ARP requests without waking system, and Respond to NS requests without waking system? If you do, are those options checked?

    If you've never configured the 3160 options in Device Manager, you need to check its settings.

  3. #3
    Join Date
    Mar 2015
    Location
    Brazil
    Posts
    8

    Default Re: ASROCK Q2900-ITX and the function wake on lan

    Quote Originally Posted by parsec View Post
    I assume you are just using the Intel 3160 wireless network card, and have nothing connected to the Realtek RTL8111GR network chip on your board?

    Do you have the Intel driver installed for the 3160 wireless card?

    I don't use a 3160 card, but in its Device Manager Properties, Power Management tab, where the WOL settings are, do you have options under Power Saver such as Respond to ARP requests without waking system, and Respond to NS requests without waking system? If you do, are those options checked?

    If you've never configured the 3160 options in Device Manager, you need to check its settings.
    1 - yes. just the wifi card, no cable !

    2 - yes. driver version 17.13.11.5

    3 - Here all the options in my system (sorry in Portuguese but I think this is the option you said)

    1 - Power Management



    Advanced options: (the value "habilitado" = enable)





    MAgic Packet wake ON - enable




    And the last - " suspend desconection WoWL" - disable




    Thank you so much !

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASROCK Q2900-ITX and the function wake on lan

    So... that did work for you?

    Sorry, it seems it did given the thank you, just want to be sure.

    Another question, does wake on LAN still work for you with those settings changed to keep the PC shutdown?

  5. #5
    Join Date
    Mar 2015
    Location
    Brazil
    Posts
    8

    Default Re: ASROCK Q2900-ITX and the function wake on lan

    Quote Originally Posted by parsec View Post
    So... that did work for you?

    Sorry, it seems it did given the thank you, just want to be sure.

    Another question, does wake on LAN still work for you with those settings changed to keep the PC shutdown?
    oh sorry....the thank you was for your answer...

    All the images are with my actual configuration....with these settings the Wake on Lan or Wan doesnt work.

    My scenario now:

    - the settings above, on windows

    - Bios:

    A) with wake on lan option ENABLE - the system doesn't off...just restarts;

    B) with wake on lan option DISABLE - the system OFF normally


    Tks.

  6. #6
    Join Date
    Dec 2014
    Location
    Taiwan
    Posts
    124

    Default Re: ASROCK Q2900-ITX and the function wake on lan

    Dear flaviocc,

    We have test Q2900-ITX wake on lane function with latest BIOS and windows 7 64 bit OS.
    Q2900-ITX can use wake on lane function normally.
    Referring to your information, you have use Wifi card as LAN device, but Q2900-ITX not support Wireless wake on lan.
    Please connect network cable and use on board LAN card to try.

    We provide some steps for enable wake on lan:
    (1)Please load BIOS default setting and change "PCIE device power on" option to "Enable" for try.
    (2)Boot into OS then shutdown system.
    (3)Now system is ready to be woken on lan by other computer.
    If still can't wake on lane please test on clean OS and provide your wake on lan tools for us to verify.

    ASRock TSD
    Eddy.

  7. #7
    Join Date
    Mar 2015
    Location
    Brazil
    Posts
    8

    Default Re: ASROCK Q2900-ITX and the function wake on lan

    Quote Originally Posted by ASRock TSD-Eddy View Post
    Dear flaviocc,

    We have test Q2900-ITX wake on lane function with latest BIOS and windows 7 64 bit OS.
    Q2900-ITX can use wake on lane function normally.
    Referring to your information, you have use Wifi card as LAN device, but Q2900-ITX not support Wireless wake on lan.
    Please connect network cable and use on board LAN card to try.

    We provide some steps for enable wake on lan:
    (1)Please load BIOS default setting and change "PCIE device power on" option to "Enable" for try.
    (2)Boot into OS then shutdown system.
    (3)Now system is ready to be woken on lan by other computer.
    If still can't wake on lane please test on clean OS and provide your wake on lan tools for us to verify.

    ASRock TSD
    Eddy.
    Eddy,


    thank you for your help and support.


    My comments:


    1 - yes...in my current scenario the wired network its impossible....IŽll try to modify this situation.


    2 - I didn't know was impossible to wake on lan (or wan) via wifi with this MOBO.....sorry for my mistake.


    3 - About the steps you wrote to me:


    A - 1 - ok ....I did that and here is the problem: If I change the option to ENABLE, my system don't shutdown....just restart.


    Do you have any tip what I have to do to shutdown the system with this option ENABLED in BIOS ??


    I have the following devices attached:


    - 2 SAMSUNG HDs in USB 3.0
    - keyboard LOGITECH K400R


    Thank you for your time.

    Flavio

  8. #8
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASROCK Q2900-ITX and the function wake on lan

    The Boot From Onboard LAN option in the BIOS controls the board's Realtek RTL8111GR wired network chip, which you do not use, right?

    Your BIOS has an option to Disable the Realtek network chip, in Chipset Configuration, called Onboard LAN. Try setting that to Disabled to stop the PC from starting when it is shutdown when Boot From Onboard LAN is enabled. As long as you don't use the Realtek network chip, set it to disabled.

    You can also disable the Realtek network chip in Device Manager.

    The Boot From Onboard LAN option probably has no effect on your wireless network card, since this option controls the onboard Realtek wired network chip.

    Try disabling Onboard LAN, but keep Boot From Onboard LAN enabled and see if the PC will stay shutdown. If the PC still restarts, set Boot From Onboard LAN to disabled.

    Have you ever tried a wake on LAN with the wireless network card, with Boot From Onboard LAN disabled?

    The PCIE Device Power On option that ASRock suggested you try to get the wireless card to wake on LAN is a good idea, but it has this description in the manual:

    PCIE Device Power On
    Allow the system to be waked up by a PCIE device and enable wake on LAN


    So if the wake on LAN option (Boot From Onboard LAN) is really the cause of the restart problem, this option seems to enable it. But IMO having the onboard Realtek network chip enabled might be the real cause of the restart problem.

  9. #9
    Join Date
    Mar 2015
    Location
    Brazil
    Posts
    8

    Default Re: ASROCK Q2900-ITX and the function wake on lan

    @parsec and @Eddy,

    my tests and results:

    1 -

    Boot From Onboard LAN - ENABLE
    Onboard LAN - ENABLE
    PCIE Device Power On - ENABLE

    The system don't Shutdown and restart
    ---------------------------------------------------------------------------------------------------------------------------------------------------------
    2 -

    Boot From Onboard LAN - DISABLE
    Onboard LAN - ENABLE
    PCIE Device Power On - ENABLE

    The system don't Shutdown and restart
    ---------------------------------------------------------------------------------------------------------------------------------------------------------
    3-

    Boot From Onboard LAN - ENABLE
    Onboard LAN - DISABLE
    PCIE Device Power On - ENABLE

    The system don't Shutdown and restart
    ---------------------------------------------------------------------------------------------------------------------------------------------------------[B]

    4-

    Boot From Onboard LAN - DISABLE
    Onboard LAN - DISABLE
    PCIE Device Power On - ENABLE

    The system don't Shutdown and restart
    ---------------------------------------------------------------------------------------------------------------------------------------------------------

    5 - all the possible combinations and the PCIE DEVICE POWER ON DISABLED - the system Shutdown normally.

    ---------------------------------------------------------------------------------------------------------------------------------------------------------
    Conclusion:

    If I Enable the PCIE DEVICE POWER ON, the system restarts and it's impossible to shutdown.....

    That info helps something ?


    @Eddy,

    my first OS with this setup was Windows 8.1 and I have a little problem (I change to windows 7 to solve this problem):

    The option to wake up the system with a keyboard or mouse (USB) never worked in windows 8 (setup in windows to device wake the system and in the BIOS). In 7 works normal.

    Tks.

    Flavio
    Last edited by flaviocc; 03-27-2015 at 07:58 AM.

  10. #10
    Join Date
    Dec 2014
    Location
    Taiwan
    Posts
    124

    Default Re: ASROCK Q2900-ITX and the function wake on lan

    Dear flaviocc,

    We have just test can't shutdown symptom on Q2900-ITX.
    Using the same configuration we did, enable three option you mentioned, system still can shutdown.
    We think maybe you can try below suggestion for further verify:
    (1)Please load BIOS default then try to enable "PCIE device power on" then remove LAN cable or wire-less card for try.
    If it related with Wireless card, please try adjust setting that you have changed.
    (2)Can't shutdown symptom may related with BIOS setting, OS setting and environment, system device etc.
    Please load BIOS default setting and only adjust "PCIE device power on" for try.
    (3)Test on a clean OS.

    If problem still remains, maybe it' a good idea to provide us some picture and more system message about can't shutdown problem.
    In addition, is there any system update? Or other info showing up?

    If any question please feel free to contact us.

    ASRock TSD
    Eddy.
    Last edited by ASRock TSD-Eddy; 03-31-2015 at 02:50 PM.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •