Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Intel MEFW Recovery Agent cannot check for updates in my Z77 Extreme6 machine




  1. #1
    Join Date
    Jan 2012
    Location
    New York City
    Posts
    118

    Default Intel MEFW Recovery Agent cannot check for updates in my Z77 Extreme6 machine

    I have a desktop built with a Z77 Extreme6 board. Last night, as I was running a defrag operation, the MEFW Recovery Agent popped up soliciting me to check for updates. I ran a check, but after several minutes, I got this message:



    I tried repeatedly, but the same message pops up, and my DSL is activated.

    Is there a procedure that I must execute in my UEFI to allow this program to check for updates? Or is it something else entirely?

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Intel MEFW Recovery Agent cannot check for updates in my Z77 Extreme6 machine

    Don't worry about that message, I have seen that on my ASRock Z77 board I don't know how many times. Never, ever, saw a message that it completed correctly, or could even connect to whatever server it tries to reach.

    I don't see that process happening on my Z87 or Z97 ASRock boards, so it must be something in the 7 series chipset compatible IME software. Or the IME firmware update process was changed in later versions and no longer shows that message.

    The error message we get might just be what is displayed regardless of what the actual cause of an update "failure". I've seen sloppy programming like this before, from anyone, even Intel and MS. Or the error message is kept ambiguous on purpose.

    Try looking at the Windows Scheduled Task entries, and you should find a line that runs that ME firmware update program. You should be able to run it from a Windows CMD prompt if you care to try. I don't see an entry for it in my Z97 board's Windows installation, although there is a different one for the "Intel Update Manager", yet another mysterious program I believe is installed with the IME software provided with every Intel board since the 6 series chipsets.

    Other things related to this might be caused by:

    + The IME firmware is embedded in the BIOS/UEFI file, the one we use to flash to a new BIOS version, the BIOS/UEFI code and other things that make up a BIOS "image". ASRock has that region of the BIOS locked, which means it cannot be updated, at least that is what some BIOS modders have said. I also see the IME firmware is locked in information supplied by the HWiNFO utility.

    + On the Z97 system I'm using now, which is an "over clocking allowed" chipset system, most of the IME features are disabled. So the usual way that the IME firmware update is done simply cannot be accomplished on any OC allowed board, which includes a Z77 board.

    The IME firmware plays a very small role on non-business/non-enterprise oriented systems, and the IME functionality is almost completely turned off, given what I think I'm seeing about it recently. I wouldn't worry about that at all. Otherwise, try contacting Intel support about it, which I'm tempted to do myself.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •